Results 1 to 9 of 9

boggin me down!

This is a discussion on boggin me down! within the General Help forums, part of the LSx Technical Help Section category; when i stomp the gas while i am cruising at normal speeds, it seems to bog down and takes a ...

  1. #1
    Member kiddynamite's Avatar
    Join Date
    Mar 2008
    Location
    Indiana
    Posts
    119

    Black
    2002 Trans Am WS-6

    boggin me down!

    when i stomp the gas while i am cruising at normal speeds, it seems to bog down and takes a second for it to go...and then when its accelerating it seems to be puttering a little and not having full power at the wheels. could this be my clutch? rear end? i had a guy tell me it might even be a back-pressure issue...any thoughts? thanks.

  2. #2
    NY Representative basballny2's Avatar
    Join Date
    Aug 2007
    Location
    NeW YoRk
    Posts
    3,393

    Red
    2001 ws6

    could be a number of things, start with the small stuff first, check your air filter and fuel filter, if those are clean let us know and the guessing game begins. Any lights on?? also m6 or a4, sometimes if its an m6 and your not in the right gear it will take a second and not feel like your getting full power

  3. #3
    Member kiddynamite's Avatar
    Join Date
    Mar 2008
    Location
    Indiana
    Posts
    119

    Black
    2002 Trans Am WS-6

    its a m6.

    the air filter is good, i havent checked the fuel filter yet. good call. i will try to do that today if i get a chance. thanks.

  4. #4
    Senior Member t-rock's Avatar
    Join Date
    Jul 2007
    Location
    pocola oklahoma
    Age
    47
    Posts
    1,121

    black
    2002 firehawk 94 Z28

    plug wires, stopped up cat, maf are one of many to check.

  5. #5
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    +1 on the MAF. If you have never cleaned it, you can buy some MAF cleaner from Autozone and try that also if your fuel filter looks OK.

  6. #6
    NY Representative basballny2's Avatar
    Join Date
    Aug 2007
    Location
    NeW YoRk
    Posts
    3,393

    Red
    2001 ws6

    to me it sounds like the fuel is being retarted (slowed down) did you check the fuel filter? let us know once u have

  7. #7
    Member kiddynamite's Avatar
    Join Date
    Mar 2008
    Location
    Indiana
    Posts
    119

    Black
    2002 Trans Am WS-6

    replacing the fuel filter today, i will def let you guys know. thanks for all the input.

  8. #8
    Member kiddynamite's Avatar
    Join Date
    Mar 2008
    Location
    Indiana
    Posts
    119

    Black
    2002 Trans Am WS-6

    replaced the fuel filter...still doing the same thing. anyone think the clutch might be going out?

  9. #9
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Clogged cat? Are you throwing any codes or no?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •