Results 1 to 4 of 4

Blowing Fuses!

This is a discussion on Blowing Fuses! within the General Help forums, part of the LSx Technical Help Section category; Well i pulled 3 codes. One was for my IAT getting "Excessive voltage" and the other 2 said my AIR ...

  1. #1
    Just a souped up sunfire. Ryans99LS1's Avatar
    Join Date
    Jun 2007
    Location
    Parma Heights, Ohio
    Age
    27
    Posts
    891

    SOM
    99 Trans Am

    Blowing Fuses!

    Well i pulled 3 codes. One was for my IAT getting "Excessive voltage" and the other 2 said my AIR solenoid and relay were bad. I checked the AIR fuse and it was blown. I replaced it, and it keeps blowing. Didnt get to the IAT sensor yet. Could the high voltage be blowing that fuse? what should i do?
    99 TA-T56 swapped, Lid, TB Bypass, LS6 Intake, !EGR, !AIR, Custom Cam, Mids, O/R-Y, 3:73s, Cutout, Flowmaster.
    A4 numbers w/ mids only 320RWHP 333RWTQ
    Cam numbers and track times soon.

    98 NBM Hardtop Formula- Bone stock, A4, 187,000 miles
    13.8@ 103 2.1 60' 1357 DA

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    The IAT sensor and secondary air are separate, don't see how P0113 would be related to the air pump circuits blowing that fuse. If you go to gearchatter.com you can look up the codes/diagnostics for your year, looked at P0113 and it even shows the wiring diagram. I'd replace the sensor if it's bad and then look at the secondary air codes.

  3. #3
    Just a souped up sunfire. Ryans99LS1's Avatar
    Join Date
    Jun 2007
    Location
    Parma Heights, Ohio
    Age
    27
    Posts
    891

    SOM
    99 Trans Am

    Yeah thats how i read the codes, i was on gearchatter. I just dont get why the system keeps blowing the fuse. I need to pass emissions but im most likely just going to back to my tuner and have him tune out the AIR and EGR system.

  4. #4
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    chances are the air pump has a shorted motor.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Blowing Air Conditioning Fuses
    By ls1camino in forum General Help
    Replies: 6
    Last Post: 07-29-2011, 06:15 PM
  2. blowing fuses car wont start need help
    By white02Z28 in forum General Help
    Replies: 4
    Last Post: 01-16-2008, 11:35 AM
  3. Blowing fuses
    By 2000 SS Beast in forum General Help
    Replies: 7
    Last Post: 10-10-2007, 10:34 PM
  4. why do i keep blowing fuses?
    By sgt0704 in forum Stereo and Electronics
    Replies: 4
    Last Post: 07-29-2006, 09:35 PM
  5. fuses keep blowing???
    By blackTA6585 in forum General Help
    Replies: 4
    Last Post: 04-06-2006, 09:27 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •