Results 1 to 12 of 12

blinkers

This is a discussion on blinkers within the General Help forums, part of the LSx Technical Help Section category; Hello all iv been reading and looking for a bit now and I can find what is going on my ...

  1. #1
    Junior Member
    Join Date
    Apr 2014
    Location
    santa rosa
    Posts
    7

    blinkers

    Hello all iv been reading and looking for a bit now and I can find what is going on my blinkers work good when the lights are off the I hit the parking lights or turn on my headlights my passenger side blinker wont blink it lights up but thats iti changed the bulb the socket and it no work I think its a bad ground but where do I start any suggestions
    Last edited by KahanaReef; 04-01-2014 at 04:26 PM.

  2. #2
    Junior Member
    Join Date
    Apr 2014
    Location
    santa rosa
    Posts
    7
    Its a 02 ws6

  3. #3
    Junior Member
    Join Date
    Aug 2005
    Location
    MA
    Posts
    18

    Black
    2002 WS6

    Did you try replacing the flasher?

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    I agree - start with the flasher and also check your bulb at the back of the car (I presume you are having issues up front).

  5. #5
    Junior Member
    Join Date
    Apr 2014
    Location
    santa rosa
    Posts
    7
    I replaced the socket bulbs all other lights work I just replaced most of the wir it had today didnt help.same issue my next move was to ask about the flasher what are other problems they have besides not blinking cuz this works good when the ligjts are off

  6. #6
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Just an idea, but try wiggling the turn signal stalk to see if the light flashes. Could be the stalk/cancel cam.

  7. #7
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Could be corrosion and a ground or resistance issue. Much like water, electricity will take the path of least resistance. Also, some of the wire routing for the lights, especially up in the front end, isn't very well protected from chaff. Are you using LED's or anything other than factory style bulbs?

  8. #8
    Junior Member
    Join Date
    Apr 2014
    Location
    santa rosa
    Posts
    7
    I have universal sockets at the moment they were out of the oem . The universals have given me problems before but I switch it out with another as well as the bulb and it works fine after. can i place ground some where on the frame of the car I tryed a spot and blew a fuse

  9. #9
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Hmmm. Any chance that you got your wiring crossed up when you spliced in the new sockets?

  10. #10
    Junior Member
    Join Date
    Apr 2014
    Location
    santa rosa
    Posts
    7
    Yea it happned the first time the polarity was reversed and it would just light up switched the wires fixed that it started working untill u turn on the lightsI really think its the flasher or something under the dash

  11. #11
    Junior Member
    Join Date
    Aug 2005
    Location
    MA
    Posts
    18

    Black
    2002 WS6

    The flasher is a piece of bi-metal that heats and cools, over time it can wear out, the higher voltage when the lights are off would work, lower when on might not?

  12. #12
    Junior Member
    Join Date
    Mar 2006
    Location
    CHESTER, VA
    Age
    49
    Posts
    11

    BLACK
    2001 WS6

    Can the flasher die just enough so that one side will blink, but the other side does not? I replaced bulbs on drivers side and cleaned out connector. The passenger side will blink. If I depress turn sig lever down for driver side, the interior arrow stays lit but does not blink. The STRANGE thing is that the front and rear turn signal lights on the driver side do TURN ON when lever depressed (not a blown bulb). They just wont blink! So, again, can the flasher under the dash die just enough to affect one side but not the other?? Thanks for your thoughts.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. blinkers
    By Marc Gomez in forum Stereo and Electronics
    Replies: 0
    Last Post: 04-02-2014, 09:07 AM
  2. Help: Why wont my new blinkers go in
    By Spikito in forum General Help
    Replies: 4
    Last Post: 07-31-2011, 03:29 PM
  3. Cant Stand My Blinkers!
    By Joez T/A in forum Firebird / WS6
    Replies: 9
    Last Post: 09-30-2007, 10:48 PM
  4. No blinkers
    By SandmanWs7 in forum General Help
    Replies: 4
    Last Post: 01-24-2007, 05:34 PM
  5. Blinkers.
    By Mr. Luos in forum General Help
    Replies: 17
    Last Post: 04-15-2006, 11:45 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •