Results 1 to 18 of 18

Blinkers.

This is a discussion on Blinkers. within the General Help forums, part of the LSx Technical Help Section category; Kind of an odd problem. All bulbs are good. Double checked them even to make sure. Anytime I flip the ...

  1. #1
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Blinkers.

    Kind of an odd problem.

    All bulbs are good. Double checked them even to make sure.

    Anytime I flip the blinker on (either direction) the lights don't flash, they just light up. This goes for the actual lights outside the car as well.

    What causes this? Bad relay?

  2. #2
    Member LS1Z28's Avatar
    Join Date
    Aug 2005
    Location
    Lake Elsinore,CA
    Posts
    280
    Camaro

    You must be low on blinker fluid. You need a new flasher that's all.

  3. #3
    Junior Member
    Join Date
    Mar 2006
    Location
    Brighton, MI
    Age
    59
    Posts
    20

    Black
    2002 Camaro Z28

    Just make sure you change the right one.

  4. #4
    SUPREME member-oderator oneBADDz's Avatar
    Join Date
    Nov 2005
    Location
    Lost in Texas
    Age
    33
    Posts
    2,683

    Custom Slate Blue
    99 B4C

    do they all light up and stay, or just one? Do they all flash with your hazards like normal?

  5. #5
    Impounded x-40oz-x's Avatar
    Join Date
    Aug 2005
    Location
    Canada
    Posts
    1,287
    1981 g-Body

    ...or there could be a shortage.

  6. #6
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    They work like they would if I would turn on either blinker.
    But they don't go on and off, they just go on.

  7. #7
    SUPREME member-oderator oneBADDz's Avatar
    Join Date
    Nov 2005
    Location
    Lost in Texas
    Age
    33
    Posts
    2,683

    Custom Slate Blue
    99 B4C

    I just ask the ?s cause there a few different scenarios which point to different things. If turns won't work but with the hazard switch they do all flash, it means DRL module. If the problem remains regardless of signals or hazards it could be a burnt pigtail or a couple other things. Just need a little more info

  8. #8
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    I will check the hazards tomorrow afternoon and get back to ya.

  9. #9
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    I lied.
    Just checked.
    Hazards flash normal. Everything flashes when the hazard switch is on.

  10. #10
    SUPREME member-oderator oneBADDz's Avatar
    Join Date
    Nov 2005
    Location
    Lost in Texas
    Age
    33
    Posts
    2,683

    Custom Slate Blue
    99 B4C

    probably a drl problem then

  11. #11
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Module eh?
    Any chance you have a part number on that?

  12. #12
    SUPREME member-oderator oneBADDz's Avatar
    Join Date
    Nov 2005
    Location
    Lost in Texas
    Age
    33
    Posts
    2,683

    Custom Slate Blue
    99 B4C

    well, I could tear my dash apart and get it for you, I don't have anything else to do and I like to see my car in pieces

    Don't go buying one now, just cause of me. I bet before too long someone will stop in and either agree with me or make me look dumb

  13. #13
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Any other ideas??

    Anyone know exactly where this module is?

  14. #14
    Member
    Join Date
    Aug 2005
    Location
    Tulsa,OK
    Age
    35
    Posts
    914

    Quick Silver
    2002 Z06

    Its mostly likely just your flasher selenoid. Just pull the panel under your steering wheel down. If you are sitting in your driver seat on the right side after the panel is off ther is a lip and a little round metal thing cliped in with 2 or 3 wires going to it. Pull it out and off and take it down to your local parts store and tell them you need a flasher selenoid. They will know what you are talking about. Should only cost about 10 bucks. It will fix your problem. The hazard system uses a different selenoid that is why they still work.

  15. #15
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Cool.
    Try that today.

  16. #16
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    It was the flasher.
    $12...all better.
    Thanks!!

  17. #17
    SUPREME member-oderator oneBADDz's Avatar
    Join Date
    Nov 2005
    Location
    Lost in Texas
    Age
    33
    Posts
    2,683

    Custom Slate Blue
    99 B4C

    crap, I really wish I could have gotten out that easy

  18. #18
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Quote Originally Posted by z_driver1
    crap, I really wish I could have gotten out that easy
    I have had PLENTY of other problems before this one with the swap.

    This was nice.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •