Results 1 to 4 of 4

bit of troubles from the start !

This is a discussion on bit of troubles from the start ! within the General Help forums, part of the LSx Technical Help Section category; 2000 Camaro SS... I seem to have a problem from the start with fishtailing.....called dealer and they tell me that ...

  1. #1
    Junior Member
    Join Date
    Sep 2011
    Location
    Topeka, Kansas, United States
    Posts
    9

    Silver
    2000 Camaro SS

    bit of troubles from the start !

    2000 Camaro SS... I seem to have a problem from the start with fishtailing.....called dealer and they tell me that i have posi limited slip 3:23 in it. Original SLP car. To me it doesnt make sence if it has a posi in it for it not to hold straight ...anyone have any ideas on what may be the problem ?

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    you're looking at it wrong.....with posi both back tires will spin and thus causing the rearend to kick out. 1 tire fire is more likely to stay in a straight line. You're answer is either less horsepower or better tires/suspension.....99.999999% of the people on the board opt for better tires/suspension.

  3. #3
    Senior Member INMY01TA's Avatar
    Join Date
    Jan 2006
    Location
    The great red state of MD.
    Posts
    5,755

    Black
    2001 Trans Am (sold)

    Let off the gas.

  4. #4
    Junior Member nfellman's Avatar
    Join Date
    Sep 2011
    Location
    Mesa, AZ
    Posts
    64

    Red
    1998 Trans Am

    ^ like they said! Build up the suspension or better tires. These cars flex quite a bit but a pair of SFC usually help that

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ABS troubles
    By spyhunt3r in forum General Help
    Replies: 3
    Last Post: 10-01-2013, 07:51 PM
  2. Help: Transmission Troubles!
    By manarth5103 in forum General Help
    Replies: 2
    Last Post: 04-27-2011, 06:30 PM
  3. Oil troubles/with vibrating
    By RedHot99T/A in forum Firebird / WS6
    Replies: 9
    Last Post: 10-12-2010, 06:21 PM
  4. 02' Sensor Troubles
    By wchorny in forum General Help
    Replies: 3
    Last Post: 07-16-2006, 10:50 AM
  5. t-top troubles...
    By delinquent543 in forum Firebird / WS6
    Replies: 15
    Last Post: 11-09-2005, 05:11 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •