Results 1 to 4 of 4

battery not getting charged

This is a discussion on battery not getting charged within the General Help forums, part of the LSx Technical Help Section category; I was driving in town and noticed the turn signals were blinking really slow, then I saw that the check ...

  1. #1
    Junior Member wolfalias's Avatar
    Join Date
    Jan 2016
    Location
    NW arkansas
    Posts
    4

    Red
    2000 Z28

    battery not getting charged

    I was driving in town and noticed the turn signals were blinking really slow, then I saw that the check gauges light was on. When I checked the gauges, the volt meter was at, or below the 12 volt mark. On the way home, about a 20 mile drive, the check gauges light would be on, then go out, then come back on. It did that all the way home. I replaced the alternator with a new one from Rockauto.com with no improvement. Any ideas? It's a 2000 Z28, 6 sp manual with traction control. Thanks for any help you can give me.

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Did you have the original alternator tested? I am trying to remember if there is a fusible link or anything in the charging system.

  3. #3
    Junior Member wolfalias's Avatar
    Join Date
    Jan 2016
    Location
    NW arkansas
    Posts
    4

    Red
    2000 Z28

    No, but I will now that's out of the car.

  4. #4
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Check all of your battery connections to be sure they are tight and not corroded.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tri-Charged
    By noxside in forum Almost Anything Goes
    Replies: 23
    Last Post: 03-07-2010, 05:08 PM
  2. Battery trade in dfw My Optima for your battery
    By Lucky 13 in forum Parts For Sale / Trade
    Replies: 2
    Last Post: 04-10-2009, 04:33 AM
  3. charged!
    By ricklo69ride in forum New Member Introductions
    Replies: 5
    Last Post: 04-29-2008, 11:23 AM
  4. Replies: 13
    Last Post: 10-25-2007, 05:43 PM
  5. won't start, battery fully charged
    By Vision in forum General Help
    Replies: 17
    Last Post: 09-26-2006, 07:36 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •