Results 1 to 14 of 14

Battery and engine light

This is a discussion on Battery and engine light within the General Help forums, part of the LSx Technical Help Section category; Hey there I`ve got a 99 camaro. The battery seems completely dead. Last week it just stopped wanting to start ...

  1. #1
    Junior Member
    Join Date
    May 2011
    Location
    england
    Posts
    16

    navy blue
    1999 camaro

    Battery and engine light

    Hey there I`ve got a 99 camaro. The battery seems completely dead. Last week it just stopped wanting to start the car and wouldn`t hold a charge. I jump started it yesterday and drove 150 miles home. It was fine on the motorway doing 80mph. As soon as I slowed down the engine light came on and it started running lumpy and sounded like it was missing. Is this likely to be a result of the battery? I figured its cause the battery isn`t getting such a charge at lower rpms?
    I`m gonna buy a battery this week, so that should tell me, but am curious and impatient to find out.

    Thanks
    Andy

  2. #2
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Sounds like your alternator is dying out on you. Check the battery first to see if the battery just won't hold a charge.

  3. #3
    Member dav-02ws6-m6's Avatar
    Join Date
    Mar 2010
    Location
    VA
    Posts
    294
    2002 trans am ws6

    you might want to check you alternator too. if the alternator isn't working it will not charge the battery and it will kill it.

  4. #4
    Member dav-02ws6-m6's Avatar
    Join Date
    Mar 2010
    Location
    VA
    Posts
    294
    2002 trans am ws6

    cammed goat beat me to it. haha

  5. #5
    Junior Member
    Join Date
    May 2011
    Location
    england
    Posts
    16

    navy blue
    1999 camaro

    The volt meter on the dash shows about 14 volts when its running. I charged it after work for about 3 hours with an old charger and it started no problem about 3 times. I was going a long way the next morning so left it on charge all night with a different newer charger I`ve got and the next morning it was flat? So we went and just took a jump starter pack.

  6. #6
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Sounds like the battery isn't holding a charge.

  7. #7
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Quote Originally Posted by cammed goat View Post
    Sounds like the battery isn't holding a charge.
    I agree.

    Take it up to the autoparts store and have them test it to double check.

  8. #8
    Junior Member
    Join Date
    May 2011
    Location
    england
    Posts
    16

    navy blue
    1999 camaro

    I`ll get it tested tomorrow. Batterys are so expensive now!

  9. #9
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Quote Originally Posted by supersmooth View Post
    Batterys are so expensive now!
    How expensive are they over there?

  10. #10
    Junior Member
    Join Date
    May 2011
    Location
    england
    Posts
    16

    navy blue
    1999 camaro

    95 on ebay. I just converted that, its $156.

  11. #11
    Junior Member
    Join Date
    May 2011
    Location
    england
    Posts
    16

    navy blue
    1999 camaro

    I just worked out fuel. Its 1.35/litre here which equates to $8.33/us gallon.

  12. #12
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Quote Originally Posted by supersmooth View Post
    95 on ebay. I just converted that, its $156.
    That's around the price for an Optima here.

  13. #13
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    $8.33/gallon!!! SHIT!!!

  14. #14
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Quote Originally Posted by supersmooth View Post
    95 on ebay. I just converted that, its $156.
    Wow, you can get a one from a local superstore for $50 here.
    Quote Originally Posted by supersmooth View Post
    I just worked out fuel. Its 1.35/litre here which equates to $8.33/us gallon.
    And I bitched about $4/gal....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Battery Drains When Engine is Hot
    By Loser in forum External Engine
    Replies: 24
    Last Post: 08-19-2013, 05:48 AM
  2. Check Engine light vs. Service Engine light
    By bigrig73 in forum Computer & Tuning
    Replies: 1
    Last Post: 04-20-2010, 07:11 AM
  3. Help: Service Engine Soon Light.engine Code No.7missfire
    By josh68 in forum General Help
    Replies: 10
    Last Post: 07-16-2008, 09:47 AM
  4. Service engine soon light = Check engine light?
    By jinxeng in forum General Help
    Replies: 5
    Last Post: 08-11-2006, 08:34 PM
  5. Replies: 14
    Last Post: 03-30-2006, 01:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •