Results 1 to 4 of 4

Batt. or Ele. Problem? ?

This is a discussion on Batt. or Ele. Problem? ? within the General Help forums, part of the LSx Technical Help Section category; my car start and drives fine. the volt meter shows between 13 and 18 volts. but when i turn it ...

  1. #1
    Manhattan Trans Am SHovV's Avatar
    Join Date
    May 2008
    Location
    Tx
    Posts
    182

    Medium Blue Metallic
    '99 T/A-7.0L-6spd

    Batt. or Ele. Problem? ?

    my car start and drives fine. the volt meter shows between 13 and 18 volts. but when i turn it off from a long drive, about 20-30 mins if i go to start it again soon it acts like the batt. is dead or really weak. also every time i start it the trip meter is reset to zero. dont know if the trip meter is normal or not. the terminalls are good and tight. no corrosion at all. the previous owner had a nitrous kit on it and im wondering if he messed something up. maybe a bad ground?

    any help is appreciated, and ill keep lookin for the problem and keep y'all updated

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Sounds like a starter/solenoid issue that acts up after being heat soaked.

  3. #3
    Member zmg00camaross's Avatar
    Join Date
    Oct 2008
    Location
    missouri
    Posts
    764

    pewter
    2000 camaro ss

    My truck did this and I found a bad ground on the engine block looked good but once removed found all the rust on the block. Cleaned off and no more problems. But also could be a starter relay or starter motor problem. Start simple first

  4. #4
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Have the battery load tested free at a parts store, gauges sweeping/trip odometer reset on the '99 cars is due to low voltage. Might not be the battery, but will eliminate it as the culprit if it checks good.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. batt drain
    By capemaydiamond in forum General Help
    Replies: 14
    Last Post: 03-01-2010, 09:05 PM
  2. Will dead batt. kill ECM?
    By truakita in forum General Help
    Replies: 4
    Last Post: 07-24-2007, 05:14 AM
  3. AC Delco Batt
    By jroc in forum Parts Review
    Replies: 40
    Last Post: 05-08-2007, 10:19 AM
  4. need help finding right batt and atlonator
    By toxik iroc in forum Stereo and Electronics
    Replies: 0
    Last Post: 12-25-2006, 06:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •