Results 1 to 3 of 3

Bad fuel pump??

This is a discussion on Bad fuel pump?? within the General Help forums, part of the LSx Technical Help Section category; Hi all, I just want to run this by some of you before I do the work on this,.. but ...

  1. #1
    Junior Member
    Join Date
    Jul 2007
    Location
    Des Moines, IA
    Posts
    18

    Blue
    1999 Camero SS

    Bad fuel pump??

    Hi all, I just want to run this by some of you before I do the work on this,.. but you all have helped me out in the past on my Camaro,.. now I need some help to fix a friend's truck. I think it's a fuel pump,.. but just want to see what some of you say.

    The other day I was with him the truck started to sputter and it died on him when we were driving, he waited about 3 mins and started the truch again and we drove it about 3 miles and all was ok.

    The next day I got up to use the truck and left the house and again, the truck did the same thing,.. after it died, I waited 3 mins or so and started it up again,.. I drove it 2 or 3 miles back to the house and this time it died on me as soon as I drove in to the drive way. I tried to started it and it would sputter and all that but it would never run.... now it won't even sputter, it just turns over.

    Before all this started to happen, I know the fuel pump was very noisy, I could hear it every time he started the truck and when he shut it off. I am kind of pointing to the pump but some ofther friends saif it could be a sensor.. any good ways to check this?

    Need some good in put.. It's a 95 Exployer Limited V6 4.0, I told him thats what the 1st problem was... but you know how it does.. I did use my Chevy to pull it up the drive way by the way

  2. #2
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,129
    Retired Outlaw Sum Bitch

    What you describe is a bad fuel pump.

  3. #3
    Junior Member
    Join Date
    Jul 2007
    Location
    Des Moines, IA
    Posts
    18

    Blue
    1999 Camero SS

    Quote Originally Posted by Sarge View Post
    What you describe is a bad fuel pump.
    Thank you sir

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel pump fuel guage issues on my '02 B4C
    By ANDYZ28 in forum Camaro / SS
    Replies: 7
    Last Post: 12-29-2014, 11:30 AM
  2. Pontiac Fuel Pumps - Do You Have The Right Fuel Pump?
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 0
    Last Post: 03-15-2011, 10:20 PM
  3. LS1 all yr fuel injectors, oe fuel rail, pump,more
    By Frost in forum Parts For Sale / Trade
    Replies: 7
    Last Post: 04-27-2009, 03:26 PM
  4. Replies: 3
    Last Post: 10-02-2006, 07:23 PM
  5. Fuel Pump Pump Problem?????? Help!
    By undertakersT/A in forum General Help
    Replies: 4
    Last Post: 04-24-2006, 10:55 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •