Results 1 to 6 of 6

Back Fire at High RBM !!

This is a discussion on Back Fire at High RBM !! within the General Help forums, part of the LSx Technical Help Section category; is it normal to back fire at high RBM's ?? normally my car do it in the 1 and 2nd ...

  1. #1
    Member Sayed_000's Avatar
    Join Date
    Oct 2008
    Location
    Middle East - Bahrain
    Posts
    257

    Pewter
    Camaro 2000 SS M6

    Back Fire at High RBM !!

    is it normal to back fire at high RBM's ??


    normally my car do it in the 1 and 2nd Gears with more than 5000 RBM

    is that normal ?

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    No... that is not normal. A backfire can be indicative of a lean condition caused by a vacuum leak, clogged injectors, or a dirty fuel filter. Start with the basics: Any codes being set? Check your fuel pressure. Check underhood for any cracked or broken vacuum lines that would allow unmetered air to enter the engine and result in a lean A/F. Fix the problem before you cause damage by driving the car. There are other possibilities, but I would start with the above.

  3. #3
    Junior Member
    Join Date
    Jul 2007
    Location
    Maryland
    Posts
    14
    look for exhaust leaks they can cause backfiring also.

  4. #4
    Member Sayed_000's Avatar
    Join Date
    Oct 2008
    Location
    Middle East - Bahrain
    Posts
    257

    Pewter
    Camaro 2000 SS M6

    thanks for the help

    my fuel filter has less than 1000k so i better go clean up my injectors ..

    had a problem with code p300 random misfire back a while and some told me its my plugs so i ordered a new tr55 set waiting for them to arrive

    and i'll see ...
    Last edited by Sayed_000; 11-18-2009 at 01:38 AM.

  5. #5
    Senior Member Redphoenix1998's Avatar
    Join Date
    Apr 2002
    Location
    San Jose
    Age
    36
    Posts
    1,897

    Red
    1998 Pontiac Trans Am

    a P0300 will cause your backfiring. Plugs and wires is a good place to start but it also be caused by a dirty MAF, vacuum leak, etc. Also run some injector cleaner through to be on the safe side

  6. #6
    Member Sayed_000's Avatar
    Join Date
    Oct 2008
    Location
    Middle East - Bahrain
    Posts
    257

    Pewter
    Camaro 2000 SS M6

    just bought new plugs .. gonna clean the injectors as well ..

    thanks guys

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: back fire:
    By starr0630 in forum Firebird / WS6
    Replies: 25
    Last Post: 01-31-2015, 07:49 AM
  2. Question: Back fire
    By SS201 in forum External Engine
    Replies: 1
    Last Post: 08-08-2010, 05:58 PM
  3. Occasional Big Back Fire
    By lsgunner28 in forum General Help
    Replies: 4
    Last Post: 04-13-2010, 03:50 AM
  4. Nitrous Back Fire
    By GTP231 in forum Multimedia Section
    Replies: 11
    Last Post: 03-18-2010, 01:35 PM
  5. Help: SLP Loudmouth 2 back fire?
    By Maro SS in forum Camaro / SS
    Replies: 41
    Last Post: 07-12-2009, 06:22 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •