Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Another Problem can you help

This is a discussion on Another Problem can you help within the General Help forums, part of the LSx Technical Help Section category; Hey i have the auto transmition and i was wondering what would be wrong whenever i hit the gas a ...

  1. #1
    Four Seat Vette 10spokess's Avatar
    Join Date
    Oct 2009
    Location
    pasadena md
    Posts
    2,034
    Blog Entries
    2

    Black
    2002 SS Camaro

    Another Problem can you help

    Hey i have the auto transmition and i was wondering what would be wrong whenever i hit the gas a pop comes from under the car and it feels like its slammin the clutch or something please help asap

  2. #2
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    Check the tranny mount. Common for them to wear and break. Also check the torque arm. I would start with those first.

  3. #3
    Four Seat Vette 10spokess's Avatar
    Join Date
    Oct 2009
    Location
    pasadena md
    Posts
    2,034
    Blog Entries
    2

    Black
    2002 SS Camaro

    Where would i get a tranny mount from and how much work would that be to get it in

  4. #4
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    Most auto parts places will carry them. Not hard to put in.

  5. #5
    Four Seat Vette 10spokess's Avatar
    Join Date
    Oct 2009
    Location
    pasadena md
    Posts
    2,034
    Blog Entries
    2

    Black
    2002 SS Camaro

    do you have to lift up the transmission

  6. #6
    Senior Member MrMasterCraft's Avatar
    Join Date
    Nov 2009
    Location
    NOVA
    Posts
    1,266

    2002 C5 - M6 - Blue
    2000 Z28 - A4 - Pewter

    Same EXACT thing happened in my last 2 LS1s (both 6 speed TAs). Feels like someone is taking a hammer to the under-side of your car, right? I replaced both with the factory torque arm mount bracket and rubber. Little over $60 from my local dealer.

    I just got done doing the polyurethane mount in this automatic (same setup as my other 2), and it was a ROYAL PITA! Both brackets have rivets, and the sides of the mount BARELY sat on each rivet, for both brackets. Pissed me off, had to take them off and use a dremel so the mount would sit flush. Even then, it was a nightmare trying to get the top bolt back through the bracket in order to spin the nut on the opposing end.

    Buddy of mine had his factory TA mount break in his cammed/nos fed LS1. He told me he drilled another hole and stuck a huge bolt and nut through, never had a problem again. Sounded a little far fetched to me, especially considering him spraying off the line on slicks and 3.73s (12 bolt). But whatever.

  7. #7
    Senior Member MrMasterCraft's Avatar
    Join Date
    Nov 2009
    Location
    NOVA
    Posts
    1,266

    2002 C5 - M6 - Blue
    2000 Z28 - A4 - Pewter

    Quote Originally Posted by 10spokess View Post
    do you have to lift up the transmission
    You don't have to support the trans, I didn't, it's 3 bolts/nuts that hold the TA mount on. Or did I......... Can't remember, because I did both the TA and trans mount at the same time, and I remember I obviously had to put a jack under the trans. If you're gunna do one, you may as well do the other while you're under there. Paid $40 for both at my local speed shop here.

  8. #8
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    For the tranny mount you will need to lift it some. If it is the torque arm mount, as MrM said they can be a PITA.

  9. #9
    Four Seat Vette 10spokess's Avatar
    Join Date
    Oct 2009
    Location
    pasadena md
    Posts
    2,034
    Blog Entries
    2

    Black
    2002 SS Camaro

    Alright kool whats a good aftermarket torque arm i might as well start my suspension mods while its broke

  10. #10
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    Quote Originally Posted by MrMasterCraft View Post
    You don't have to support the trans, I didn't, it's 3 bolts/nuts that hold the TA mount on. Or did I......... Can't remember, because I did both the TA and trans mount at the same time, and I remember I obviously had to put a jack under the trans. If you're gunna do one, you may as well do the other while you're under there. Paid $40 for both at my local speed shop here.
    Beat me to it! Need to wait till I get home to do this lol. Phones just dont work that well.

  11. #11
    Senior Member MrMasterCraft's Avatar
    Join Date
    Nov 2009
    Location
    NOVA
    Posts
    1,266

    2002 C5 - M6 - Blue
    2000 Z28 - A4 - Pewter

    Quote Originally Posted by 10spokess View Post
    Alright kool whats a good aftermarket torque arm i might as well start my suspension mods while its broke
    Go to Group Purchase Resquest RIGHT NOW and put a submission in for one, under my post! I've already got one going right now, because mine is twisted... GREAT TIME to buy one!

  12. #12
    Four Seat Vette 10spokess's Avatar
    Join Date
    Oct 2009
    Location
    pasadena md
    Posts
    2,034
    Blog Entries
    2

    Black
    2002 SS Camaro

    is it safe to drive with a broken one???

  13. #13
    Member
    Join Date
    Aug 2005
    Location
    Tulsa,OK
    Age
    37
    Posts
    914

    Quick Silver
    2002 Z06

    Its bad on your u-joints and puts stress on motor mounts. So technically no.. Your not going to get stranded by doing so though..

    Just put the car up on jack stands and support the tranny with your jack. Its a 30min job. Maybe a little more if you have to get out from under the car a couple times for sockets.


    Slow Passenger Window - Want Passenger Express Down - Tired of Replacing DayTime Running Light Bulbs

    Camaro Owners Click Here
    Firebird Owners Click Here

    Need instructions to replace your F-Body window motor?
    www.AutoTrix.net

  14. #14
    Four Seat Vette 10spokess's Avatar
    Join Date
    Oct 2009
    Location
    pasadena md
    Posts
    2,034
    Blog Entries
    2

    Black
    2002 SS Camaro

    i just dont have anything to replace it with where can you get a quick reliable one

  15. #15
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Check local parts stores for trans mounts. As for torque arms, special order from dealer or check local junkyards.

  16. #16
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    22174970 is the part number for the auto trans stock mount. You can find that at www.gmpartsdirect.com also.

  17. #17
    Four Seat Vette 10spokess's Avatar
    Join Date
    Oct 2009
    Location
    pasadena md
    Posts
    2,034
    Blog Entries
    2

    Black
    2002 SS Camaro

    Got it fixed today for 60bucks still looking to buy a torque arm and subframes plus relocation brackets and shocks i figure what the hell ill do the suspension now

  18. #18
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Hit up the sponsors here. Time to rock and roll.

  19. #19
    Four Seat Vette 10spokess's Avatar
    Join Date
    Oct 2009
    Location
    pasadena md
    Posts
    2,034
    Blog Entries
    2

    Black
    2002 SS Camaro

    heck yeah i dont know which one to start with theres so many

  20. #20
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    KY Speed is an excellent sponsor here.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. cluth problem??? transmission problem???? please HELP!!!
    By adamblake97 in forum Manual Transmission
    Replies: 3
    Last Post: 04-07-2014, 08:34 AM
  2. Obama's Woman Problem A Problem Of His Own Making
    By Ed Blown Vert in forum Political / Debate Forum
    Replies: 0
    Last Post: 01-14-2013, 03:50 PM
  3. Fuel Problem or Severe Engine Problem
    By pet_monk in forum General Help
    Replies: 3
    Last Post: 02-18-2008, 08:51 AM
  4. Electrical/charging problem problem
    By jchcomputers in forum General Help
    Replies: 4
    Last Post: 02-23-2007, 06:59 AM
  5. is it a clutch problem, or a tranny problem?
    By sgt0704 in forum Manual Transmission
    Replies: 3
    Last Post: 01-07-2007, 05:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •