Results 1 to 10 of 10

air pump

This is a discussion on air pump within the General Help forums, part of the LSx Technical Help Section category; ok so i think my z28 is curse by the devil. No matter what i do the freaking service engine ...

  1. #1
    REAPER Z28 reaper ws6's Avatar
    Join Date
    Apr 2009
    Location
    Tyler TX
    Age
    28
    Posts
    516

    Navy Blue Metallic/Black
    02 camaro z28/01 wife t/a

    air pump

    ok so i think my z28 is curse by the devil. No matter what i do the freaking service engine light wont come off its been on since i both the car. First it was the 02 sensors (replace that) then it was the clutch switch (replace that) and now is telling me that my air pump is bad. I replace the air pump i also replace the relay switch but its still showing that is bad any ideas on what it could be? before i take it to the shop to get it figure out?..

  2. #2
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    What codes are you getting? Is the pump making noise when you turn the car on? It sounds like air vaccum pump for a few seconds.

    If is not making noise have you checked the AIR pump fuse? Are you sure your check valves are not the issue? Check valves are known to cause trouble.

  3. #3
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71


  4. #4
    REAPER Z28 reaper ws6's Avatar
    Join Date
    Apr 2009
    Location
    Tyler TX
    Age
    28
    Posts
    516

    Navy Blue Metallic/Black
    02 camaro z28/01 wife t/a

    Quote Originally Posted by JayTA98 View Post
    What codes are you getting? Is the pump making noise when you turn the car on? It sounds like air vaccum pump for a few seconds.

    If is not making noise have you checked the AIR pump fuse? Are you sure your check valves are not the issue? Check valves are known to cause trouble.
    yeah i replace the air pump fuse...and were is the check valve located??

  5. #5
    REAPER Z28 reaper ws6's Avatar
    Join Date
    Apr 2009
    Location
    Tyler TX
    Age
    28
    Posts
    516

    Navy Blue Metallic/Black
    02 camaro z28/01 wife t/a

    Quote Originally Posted by Cutlass View Post
    thanks bro that really help a lot

  6. #6
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Glad to help a fellow enthusiast

  7. #7
    Junior Member nmbr5ml's Avatar
    Join Date
    Jan 2011
    Location
    LaVista, NE
    Posts
    8

    Pewter
    2000 Camaro SS

    What I found to be the most common cause of the Secondary Air Injection code, when I still had my AIR system installed, was simple fouling in the check valve. I simply removed those at the exhaust manifold and the hose to the intake, ran some carb cleaner through them and reinstalled. I cleared the code with my programmer, but it never came back after I did this.

    This is just my opinion, but unless you need the AIR or are keeping your car all stock as a collector, I would remove the system and have it tuned out before I paid anyone to repair it. Clearing out the check valves is very easy though, and has been the cause of every code I've seen in my or buddies' cars.

  8. #8
    Member jsmith564`'s Avatar
    Join Date
    Apr 2009
    Location
    covington ga
    Age
    32
    Posts
    481

    yellow
    2004 gto

    i dont know if this will help you or not, but i pulled the whole air pump lines exc off my car.

    i will give it to you if you pay for shipping. if it works out for you, you could take what you bought back to the store to collect some gas money. eveything worked fine while it was on my car which is an 02 ss.

    pm me if you want it.

  9. #9
    REAPER Z28 reaper ws6's Avatar
    Join Date
    Apr 2009
    Location
    Tyler TX
    Age
    28
    Posts
    516

    Navy Blue Metallic/Black
    02 camaro z28/01 wife t/a

    Quote Originally Posted by nmbr5ml View Post
    What I found to be the most common cause of the Secondary Air Injection code, when I still had my AIR system installed, was simple fouling in the check valve. I simply removed those at the exhaust manifold and the hose to the intake, ran some carb cleaner through them and reinstalled. I cleared the code with my programmer, but it never came back after I did this.

    This is just my opinion, but unless you need the AIR or are keeping your car all stock as a collector, I would remove the system and have it tuned out before I paid anyone to repair it. Clearing out the check valves is very easy though, and has been the cause of every code I've seen in my or buddies' cars.
    yeah my air pump is running so it must be what you said ill give it a try and see what happens. thanks

  10. #10
    REAPER Z28 reaper ws6's Avatar
    Join Date
    Apr 2009
    Location
    Tyler TX
    Age
    28
    Posts
    516

    Navy Blue Metallic/Black
    02 camaro z28/01 wife t/a

    Quote Originally Posted by jsmith564` View Post
    i dont know if this will help you or not, but i pulled the whole air pump lines exc off my car.

    i will give it to you if you pay for shipping. if it works out for you, you could take what you bought back to the store to collect some gas money. eveything worked fine while it was on my car which is an 02 ss.

    pm me if you want it.
    thanks man ill get back to you after i try to clean mine out...thanks a lot for your offer.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil pump ?
    By Mich's04 in forum GTO
    Replies: 16
    Last Post: 10-13-2008, 07:39 PM
  2. air pump
    By binnie2424 in forum Camaro / SS
    Replies: 12
    Last Post: 09-15-2008, 07:44 PM
  3. Power Steering pump leak?! new pump or seal kit?
    By JehalinTA in forum General Help
    Replies: 2
    Last Post: 03-18-2008, 11:05 PM
  4. air pump Q
    By pipes_ta in forum Firebird / WS6
    Replies: 3
    Last Post: 10-14-2006, 08:25 PM
  5. Fuel Pump Pump Problem?????? Help!
    By undertakersT/A in forum General Help
    Replies: 4
    Last Post: 04-24-2006, 10:55 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •