Page 2 of 2 FirstFirst 12
Results 21 to 28 of 28

air pump

This is a discussion on air pump within the General Help forums, part of the LSx Technical Help Section category; The thread Cutlass linked has a simple diagnostic procedure to determine where the problem is. Most of the time it ...

  1. #21
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    The thread Cutlass linked has a simple diagnostic procedure to determine where the problem is. Most of the time it is the check valves that go bad. Our car came with the SES light on thanks to bad valves -- other than the fact that they were a bear to unscrew, it was a cheap and easy fix.

    --------------------------------------------------------

    Just realized I already answered this question and the diagnostic thread has been linked twice. Did you go through and check everything out?
    Last edited by pajeff02; 11-07-2010 at 07:11 PM. Reason: Re-read thread.

  2. #22
    Junior Member spedos's Avatar
    Join Date
    Oct 2010
    Location
    Beloit Wisconsin
    Posts
    24

    Grey
    1999 Trans am

    Air pump

    I have air flowing into the check valves so i am going to purchase new ones and see if the tubes going into the manifold have build up in them will post later thanks for all the help.
    Went and had codes checked again came up as p1416 Air system bank one is this still something with secondary air system
    Last edited by spedos; 11-08-2010 at 06:50 AM. Reason: Add more info

  3. #23
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    I found it easier to remove the check valves with the pipes removed from the manifolds. If you are careful you can re-use the gaskets -- just don't snap a bolt off trying to remove them. My check valves needed assistance with a "heat wrench" to get them to break free.

  4. #24
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    So glad my engine did'nt come with a smog pump..
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  5. #25
    Junior Member spedos's Avatar
    Join Date
    Oct 2010
    Location
    Beloit Wisconsin
    Posts
    24

    Grey
    1999 Trans am

    Well I changed the check valves and the solenoid connected to the air pump went and had codes cleared so now will wait to see if sea comes back thanks again for all the help.

  6. #26
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,997

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Quote Originally Posted by spedos View Post
    Cutlass what would you suggest I take the air pump off or find the problem and have it fixed. Just want to do the best thing for my car.
    I removed my AIR system, along with the EGR, Cat converters, and Skip Shift with help from Frost's mail order tune.

  7. #27
    Junior Member spedos's Avatar
    Join Date
    Oct 2010
    Location
    Beloit Wisconsin
    Posts
    24

    Grey
    1999 Trans am

    Just an update been about a week now and so far no see light so thanks again for all the help guys. Just dropped car off yesterday to be repainted same color but it needs to be redone to be immaculate.

  8. #28
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Good to hear!

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil pump ?
    By Mich's04 in forum GTO
    Replies: 16
    Last Post: 10-13-2008, 07:39 PM
  2. air pump
    By binnie2424 in forum Camaro / SS
    Replies: 12
    Last Post: 09-15-2008, 07:44 PM
  3. Power Steering pump leak?! new pump or seal kit?
    By JehalinTA in forum General Help
    Replies: 2
    Last Post: 03-18-2008, 11:05 PM
  4. air pump Q
    By pipes_ta in forum Firebird / WS6
    Replies: 3
    Last Post: 10-14-2006, 08:25 PM
  5. Fuel Pump Pump Problem?????? Help!
    By undertakersT/A in forum General Help
    Replies: 4
    Last Post: 04-24-2006, 10:55 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •