Results 1 to 10 of 10

add coolant light coming on sporadically

This is a discussion on add coolant light coming on sporadically within the General Help forums, part of the LSx Technical Help Section category; hello! i have a '98 z28 with 210,000 trouble free miles on it. i bought it new. all i've done ...

  1. #1
    Junior Member
    Join Date
    Aug 2011
    Location
    United States
    Posts
    1

    black
    98 z28

    add coolant light coming on sporadically

    hello! i have a '98 z28 with 210,000 trouble free miles on it. i bought it new. all i've done is change belts and hoses a couple of times, a fuel filter, a coolant flush twice and...that's about it. i use mobil 1 oil and change it about every 5,000 miles. i love my camaro.

    now the add coolant light comes on sometimes. the temperature is always in the lower middle of the normal range. the car runs great. i opened what i believe is the radiator surge tank fill cap, when the car was slightly warm, and the coolant was almost up to the brim. so it does not look like i could add coolant if i tried.

    so, what's up with this? i'm sure there is a lot of knowledge here. thanks in advance for your input.

    steven

  2. #2
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    What's the level in the the reservoir?

    The level sensor might be on it's way out as well and may need replacing.

  3. #3
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    ^^ This. '98 was the only year with an actual working temp gauge, so you can generally trust that. Never remove the radiator cap when the system is hot -- even the overflow bottle I check when cold just to be safe in case the vent tube is blocked up. If the level on your overflow bottle's dipstick is in the proper range, and the level in the radiator is near the top, I agree that it is probably a faulty sensor.

  4. #4
    Senior Member cpop98ws6's Avatar
    Join Date
    May 2010
    Location
    Wilkes-Barre, PA
    Posts
    1,545

    Black/Black
    98 WS6/04 Sierra Dmax

    ^^^ Agreed with the faulty sensor. Mine comes on every now and then to, mostly when its cold.

  5. #5
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    Like everyone said, 98s came with the sensor and they usually go bad. I just unplugged it on my 98 and it shut off the light.

  6. #6
    Member wicked1's Avatar
    Join Date
    Oct 2005
    Location
    West Virginia
    Posts
    104

    Black
    1999 Trans Am

    I have a 99 TA that also has the sensor. Had the same problem and unplugged it. If you take care of your car and perform routine maintenence on it you dont need the sensor. But what happens is the sensor is extremely sensitive. And the stuff that coats the inside of your radiator gets on it making it dirty and it says the coolant is low. GM knew this was a problem and thats why the 2000 and later models dont have the sensor.

  7. #7
    Member
    Join Date
    Mar 2007
    Location
    NC
    Posts
    421

    NBM
    1998Z28

    Quote Originally Posted by wicked1 View Post
    I have a 99 TA that also has the sensor. Had the same problem and unplugged it. If you take care of your car and perform routine maintenence on it you dont need the sensor. But what happens is the sensor is extremely sensitive. And the stuff that coats the inside of your radiator gets on it making it dirty and it says the coolant is low. GM knew this was a problem and thats why the 2000 and later models dont have the sensor.
    I'm glad you said you can unplug it and get rid of the alarm. My 98 does it every once in a blue moon.

  8. #8
    Member wicked1's Avatar
    Join Date
    Oct 2005
    Location
    West Virginia
    Posts
    104

    Black
    1999 Trans Am

    Yep, its a small plug on the passenger side of the radiator.
    Quote Originally Posted by PFM View Post
    I'm glad you said you can unplug it and get rid of the alarm. My 98 does it every once in a blue moon.

  9. #9
    Retired NOT tired SteveC's Avatar
    Join Date
    Jul 2005
    Location
    Poway, Ca
    Posts
    1,126

    SOM
    2001 Z28 (Sara)

    Quote Originally Posted by cpop98ws6 View Post
    ^^^ Agreed with the faulty sensor. Mine comes on every now and then to, mostly when its cold.
    X2 on that.

    SteveC

  10. #10
    Member TA98's Avatar
    Join Date
    Mar 2009
    Location
    Maryland
    Posts
    863

    Black
    1998 Trans Am

    i just unplugged mine. and just take the cap off and check periodically

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. help coolant leak coming from????
    By jman0322 in forum General Help
    Replies: 5
    Last Post: 11-26-2007, 04:34 PM
  2. low coolant light
    By divinezx9 in forum LT1
    Replies: 9
    Last Post: 04-12-2007, 12:44 PM
  3. Coolant light...coolant level full.
    By SR71 in forum General Help
    Replies: 4
    Last Post: 01-08-2007, 10:35 AM
  4. coolant light on, full on coolant
    By Brownboy2020 in forum Firebird / WS6
    Replies: 10
    Last Post: 08-10-2006, 01:26 PM
  5. Low coolant light?????
    By 79JON in forum General Help
    Replies: 9
    Last Post: 06-05-2006, 04:14 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •