Results 1 to 2 of 2

AC Problem

This is a discussion on AC Problem within the General Help forums, part of the LSx Technical Help Section category; I have had a slow leak in AC system that is getting worse. When the AC first quit working, my ...

  1. #1
    Western Maryland LS1's
    Join Date
    Nov 2005
    Location
    Maryland
    Age
    61
    Posts
    51

    Red
    1999 Camaro SS

    AC Problem

    I have had a slow leak in AC system that is getting worse. When the AC first quit working, my neighborhood (professional) mechanic put his gauge on said it was low and charged it and it worked for a few months. The next time it quit working, he took it to work and used the AC diagnostic equipment at the (Nissan) dealer where he works, put the dye in, looked for leaks and couldnt see any. He concluded that it must be under the dash. He said that is an expensive repair due to stripping the dash out and said if it only needs a charge or two throughout the summer that it wouldn't be worth it. Well it has gotten worse and I am thinking of stripping the dash out and taking it to him for the AC reapir and then re-installing the dash to save some money on labor. Any AC stories that might help would be welcome. Thanks

  2. #2
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Have him recharge it with more dye. Then go to him after a couple of weeks to see if he sees a leak.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. cluth problem??? transmission problem???? please HELP!!!
    By adamblake97 in forum Manual Transmission
    Replies: 3
    Last Post: 04-07-2014, 08:34 AM
  2. Obama's Woman Problem A Problem Of His Own Making
    By Ed Blown Vert in forum Political / Debate Forum
    Replies: 0
    Last Post: 01-14-2013, 03:50 PM
  3. Fuel Problem or Severe Engine Problem
    By pet_monk in forum General Help
    Replies: 3
    Last Post: 02-18-2008, 08:51 AM
  4. Electrical/charging problem problem
    By jchcomputers in forum General Help
    Replies: 4
    Last Post: 02-23-2007, 06:59 AM
  5. is it a clutch problem, or a tranny problem?
    By sgt0704 in forum Manual Transmission
    Replies: 3
    Last Post: 01-07-2007, 05:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •