Results 1 to 4 of 4

AC Problem 1998 Z-28

This is a discussion on AC Problem 1998 Z-28 within the General Help forums, part of the LSx Technical Help Section category; I have a 98 Z-28, and I only get hot air through the vents when AC is on. The compressor ...

  1. #1
    Junior Member
    Join Date
    Jul 2009

    1998 Z-28

    Smile AC Problem 1998 Z-28

    I have a 98 Z-28, and I only get hot air through the vents when AC is on. The compressor is functioning properly and the system is completely charged. If anybody knows a fix for this please let me know thanks

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Jacksonville, FL
    What are the low and high side pressures/sure it's charged correctly? Is just the center vents or all settings? First thing I'd do is check the static pressure (car off) if it's not cooling in any mode.

  3. #3
    Member headpecker's Avatar
    Join Date
    May 2009

    2000 ss camaro

    You probly have a blockage somewhere.Mine was doing something similiar,turned out the dryer/reciever had some crap in it.Could also be in the orifice tube(easy fix).

  4. #4
    Junior Member
    Join Date
    Jul 2009
    Lincoln ne

    98 camaro Z28

    another easy way to look for a blockage in your system is to see where you start to see condensation on the hoses. that will let you know where your restriction is. also check to make sure you have enough coolant in your radiator and enough air flow through your condenser. ie a bad cooling fan or a walmart bag stuck to it, i have seen it before. or to many bugs. good luck feel free to PM me with ?'s.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pittsburgh Penguins 1998 Corvette - Hat Trick
    By Ed Blown Vert in forum Corvette
    Replies: 0
    Last Post: 01-15-2008, 04:30 PM
  2. Please Help With My Problem
    By my00blackta in forum Computer & Tuning
    Replies: 15
    Last Post: 11-29-2006, 02:38 PM
  3. Having somewhat of a problem...
    By Lone Lobo in forum General Help
    Replies: 10
    Last Post: 11-23-2006, 03:36 PM
  4. Very Strange Gauges Problem
    By Friptzap in forum General Help
    Replies: 4
    Last Post: 09-18-2006, 06:19 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts