Results 1 to 3 of 3

ac problem

This is a discussion on ac problem within the General Help forums, part of the LSx Technical Help Section category; any one know why my ac compressor doesnt kick on.. i check the relays but the pump still doesnt activate...help...

  1. #1
    Junior Member
    Join Date
    May 2009
    Location
    california
    Posts
    1

    impulse blue
    04 6spd

    ac problem

    any one know why my ac compressor doesnt kick on.. i check the relays but the pump still doesnt activate...help

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    You will get a better response posting this question in the General Help section.

    It may be that the system simply needs re-charged. There is a switch on the high pressure line that will not allow the compressor to run if the system pressure is too low. I usually jump the switch connector momentarily -- if the compressor clutch engages then that is your problem. If not, the problem lies elsewhere in the system. If after re-charging the system leaks down again, you will need to have it dye tested.

  3. #3
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Most likely the refrigerant has leaked out. If so, have recharged with fluorescent tracer dye at the same time. If its a slow leak, then take it back to the shop when in 200 to 500 miles to have it recheck the system for leaks with a black light.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. cluth problem??? transmission problem???? please HELP!!!
    By adamblake97 in forum Manual Transmission
    Replies: 3
    Last Post: 04-07-2014, 08:34 AM
  2. Obama's Woman Problem A Problem Of His Own Making
    By Ed Blown Vert in forum Political / Debate Forum
    Replies: 0
    Last Post: 01-14-2013, 03:50 PM
  3. Fuel Problem or Severe Engine Problem
    By pet_monk in forum General Help
    Replies: 3
    Last Post: 02-18-2008, 08:51 AM
  4. Electrical/charging problem problem
    By jchcomputers in forum General Help
    Replies: 4
    Last Post: 02-23-2007, 06:59 AM
  5. is it a clutch problem, or a tranny problem?
    By sgt0704 in forum Manual Transmission
    Replies: 3
    Last Post: 01-07-2007, 05:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •