Page 1 of 2 12 LastLast
Results 1 to 20 of 21

AC only blows to the floor?!?!?

This is a discussion on AC only blows to the floor?!?!? within the General Help forums, part of the LSx Technical Help Section category; Anyone else have this? I try any setting (Max, combo, defrost, vent, etc...) and all the ac blows to the ...

  1. #1
    Junior Member
    Join Date
    Oct 2005
    Location
    houston, tx
    Age
    32
    Posts
    72

    Black
    1999 Camaro SS

    AC only blows to the floor?!?!?

    Anyone else have this? I try any setting (Max, combo, defrost, vent, etc...) and all the ac blows to the floor as if something is blocking it from coming to the vents. On defrost some AC kind of comes out of the dash (more than trying it through the vents) but not as much as it should even with the fan blasting. What could be causing this?
    1999 Camaro SS 6 Speed

  2. #2
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    You could have a vacuum leak either under hood or under dash or both..
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  3. #3
    Senior Member Z28_Driver's Avatar
    Join Date
    Jun 2009
    Location
    Ohio
    Posts
    1,017

    Sunset Orange Metallic
    2002 Z28 Hardtop

    Have you had the car long? Could be an something blocking the vent. Could be a problem with the device that controls the air flow inside the ducting. (sorry, can't remember the name)

  4. #4
    Member nillam1's Avatar
    Join Date
    Apr 2009
    Location
    Toronto, Ontario, Canada.
    Posts
    392

    Red
    2002 Camaro Z28

    Thumbs up

    Quote Originally Posted by chris5 View Post
    Anyone else have this? I try any setting (Max, combo, defrost, vent, etc...) and all the ac blows to the floor as if something is blocking it from coming to the vents. On defrost some AC kind of comes out of the dash (more than trying it through the vents) but not as much as it should even with the fan blasting. What could be causing this?
    Ya, the selector switch is activated by vacuum pressure, check for vacuum leaks in the hoses on the engine. I have never had this problem, though I hope it is an easy fix for you. Good luck, let us know how you fix it so we can be prepared.
    2002 Camaro Z28 Bolt ons, Flowmaster catback w/3" QTP electric cutout, Superchips tuned, Granatelli MAF, SLP cold air induction Lid & filter, ZEX powertune plugs, Taylor 10.4mm wires, 160 T-stat w/fan control, Eibach sportlines & BFG-KDW's on 17" SLP SS rims.

  5. #5
    Junior Member
    Join Date
    Oct 2005
    Location
    houston, tx
    Age
    32
    Posts
    72

    Black
    1999 Camaro SS

    Quote Originally Posted by Z28_Driver View Post
    Have you had the car long? Could be an something blocking the vent. Could be a problem with the device that controls the air flow inside the ducting. (sorry, can't remember the name)
    have had the car since 01, just started happening. i am kind of a moron when it comes to cars now, is it still safe to drive around with a possible vacuum leak?

  6. #6
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by chris5 View Post
    have had the car since 01, just started happening. i am kind of a moron when it comes to cars now, is it still safe to drive around with a possible vacuum leak?
    Yeah for now, but eventually it may lead to idleing and drivablity issues..

  7. #7
    Senior Member bills98ta's Avatar
    Join Date
    Feb 2007
    Location
    St Thomas, PA
    Posts
    5,047

    White
    1998 Trans Am

    The vacuum hose is the little one one the back of the intake manifold. Might need a mirror to see it. Comes from the passenger side around the AC / heater box...

  8. #8
    Junior Member
    Join Date
    Oct 2005
    Location
    houston, tx
    Age
    32
    Posts
    72

    Black
    1999 Camaro SS

    my question is....could this just be a mechanical thing? like the selector switch is messed up and just stuck on floor?

  9. #9
    Senior Member bills98ta's Avatar
    Join Date
    Feb 2007
    Location
    St Thomas, PA
    Posts
    5,047

    White
    1998 Trans Am

    The switch is a vaccuum controller. Ussally when they go bad, you here the vaccuum hissing in the dash.

  10. #10
    Member DaddySS's Avatar
    Join Date
    Oct 2005
    Location
    Bergen Co. NJ
    Posts
    590

    Black
    2000 Camaro SS Conv.

    Check that the small vacuum hose in the passenger rear engine compartment right by the A/C unit is still attached.

  11. #11
    Senior Member redbird555's Avatar
    Join Date
    Mar 2009
    Location
    pompano beach florida
    Age
    27
    Posts
    1,008
    2002 Camaro Z/28 Pewter

    Had this happen on my buddies car. Open the hood and look by the pcm you will see a small check valve his was cracked and was causing the issue its like a 2 dollar part in the help section at otterzone.

  12. #12
    Member nillam1's Avatar
    Join Date
    Apr 2009
    Location
    Toronto, Ontario, Canada.
    Posts
    392

    Red
    2002 Camaro Z28

    Quote Originally Posted by chris5 View Post
    Anyone else have this? I try any setting (Max, combo, defrost, vent, etc...) and all the ac blows to the floor as if something is blocking it from coming to the vents. On defrost some AC kind of comes out of the dash (more than trying it through the vents) but not as much as it should even with the fan blasting. What could be causing this?
    Git er done, yet? What was the prob?

  13. #13
    Junior Member
    Join Date
    Oct 2005
    Location
    houston, tx
    Age
    32
    Posts
    72

    Black
    1999 Camaro SS

    Quote Originally Posted by nillam1 View Post
    Git er done, yet? What was the prob?
    all the hoses are attatched fine. i have no time in between work and practices to take her in, maybe this weekend i will get a chance.

  14. #14
    Junior Member
    Join Date
    Oct 2005
    Location
    houston, tx
    Age
    32
    Posts
    72

    Black
    1999 Camaro SS

    okay so i took it to the shop today and they say it's the controller switch in the dash has gone bad and it will be $98 for labor and $298 for the part?!?!?! i take my car to this shop a lot and trust them but this sounds outrageous. they say that is what gm charges for the part. what do you think?
    Last edited by chris5; 10-02-2009 at 02:55 PM.

  15. #15
    lmpounded SandmanWs7's Avatar
    Join Date
    Jan 2006
    Location
    Dallas, Texas
    Posts
    8,028

    Silver
    2007 CTS-V

    Quote Originally Posted by chris5 View Post
    okay so i took it to the shop today and they say it's the controller switch in the dash has gone bad and it will be $98 for labor and $298 for the part?!?!?! i take my car to this shop a lot and trust them but this sounds outrageous. they say that is what gm charges for the part. what do you think?


    They are just trying to take your money. Have you checked the hoses mentioned and the check valve?

  16. #16
    lmpounded SandmanWs7's Avatar
    Join Date
    Jan 2006
    Location
    Dallas, Texas
    Posts
    8,028

    Silver
    2007 CTS-V

    If by control switch they mean the dials, Go to rockauto dot com and look up the switch control there. Its less than half of what they want. Then all you do is pull yours out, disconnect the harness and plug it to the new one and re install it.

  17. #17
    Junior Member
    Join Date
    Oct 2005
    Location
    houston, tx
    Age
    32
    Posts
    72

    Black
    1999 Camaro SS

    Quote Originally Posted by SandmanWs7 View Post
    If by control switch they mean the dials, Go to rockauto dot com and look up the switch control there. Its less than half of what they want. Then all you do is pull yours out, disconnect the harness and plug it to the new one and re install it.
    he exact term he used was "ac control head". so it is not the dials. anyone heard of this part?

  18. #18
    lmpounded SandmanWs7's Avatar
    Join Date
    Jan 2006
    Location
    Dallas, Texas
    Posts
    8,028

    Silver
    2007 CTS-V

    Quote Originally Posted by chris5 View Post
    he exact term he used was "ac control head". so it is not the dials. anyone heard of this part?
    Google it. Its the WHOLE unit, not just the dials. Which is for sale on the website for less than a $100.

  19. #19
    Senior Member Z28_Driver's Avatar
    Join Date
    Jun 2009
    Location
    Ohio
    Posts
    1,017

    Sunset Orange Metallic
    2002 Z28 Hardtop

    HVAC head unit. Mine went bad under warranty. It was about $300 for the part at that time. I didn't even consider that part. When it went bad I had no heat or air or blower.
    Not sure if thats the right diagnosis, but that part can be had for less. Spend a little time on google or go to a junk yard.

  20. #20
    Junior Member
    Join Date
    Oct 2005
    Location
    houston, tx
    Age
    32
    Posts
    72

    Black
    1999 Camaro SS

    Quote Originally Posted by SandmanWs7 View Post
    Google it. Its the WHOLE unit, not just the dials. Which is for sale on the website for less than a $100.
    which website did you find this on? i can't seem to find any when i search it.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. A/C blows hot
    By 00hawk109 in forum General Help
    Replies: 8
    Last Post: 07-06-2011, 12:07 PM
  2. Question: AC only blows out into floor
    By Speedy_Gonzales in forum External Engine
    Replies: 16
    Last Post: 06-03-2009, 02:16 AM
  3. when it blows, what breaks?
    By LT1 > LS1 in forum Drivetrain
    Replies: 12
    Last Post: 09-14-2008, 01:02 PM
  4. A/C blows cold only sometimes now...
    By AKIRA in forum General Help
    Replies: 1
    Last Post: 03-27-2008, 05:54 PM
  5. A/C blows warm
    By doggles13 in forum General Help
    Replies: 4
    Last Post: 05-09-2007, 08:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •