Results 1 to 4 of 4

98 t/a...is it a problem?

This is a discussion on 98 t/a...is it a problem? within the General Help forums, part of the LSx Technical Help Section category; I am looking into possibly purchasing a 98 t/a from someone I know. Lookin for some help before I make ...

  1. #1
    Junior Member
    Join Date
    Jan 2006
    Location
    York, PA
    Posts
    18

    98 t/a...is it a problem?

    I am looking into possibly purchasing a 98 t/a from someone I know. Lookin for some help before I make the decision. He says that the car randomly has the low coolant light come on, although he has taken it to GM and they say nothing is wrong. Could someone tell me why this is? Also he said "a cylinder in the engine broke around 62k." The car has 72k on it, GM fixed the cylinder since it was still under warranty. I am wondering what anyone thinks about any of this and what do you guys recommend I make my max to pay for this vehicle? Its a WS-6 version, w/ttops. Thanks guys

  2. #2
    Member
    Join Date
    Aug 2005
    Location
    Tulsa,OK
    Age
    36
    Posts
    914

    Quick Silver
    2002 Z06

    Well as for the coolant light. That is a common problem for the sensor to actually go bad on the radiator by the lid. Mine did the same thing, just replaced the sensor and it does not come on anymore. As for the Price it depends on how well it was maintainted. You should also get him to clear up what exactly broke about the cylinder.

  3. #3
    Member Sprfstz28's Avatar
    Join Date
    Dec 2005
    Location
    Indiana
    Age
    34
    Posts
    153

    Black
    97 z28

    I agree on checking more into the "cylinder" problem.. But I also had the same thing happen with the coolant sensor, as gnomee said, after I replaced the sensor, I never had another problem..
    -SprFstZ28

  4. #4
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Pittsburgh, PA
    Age
    35
    Posts
    21,719

    My life is a
    Ben Stiller movie.

    98's are the first of the late 4th gen t/a's but second year for the LS1 engine [ls1's were first in 97 vettes] If that car is under 75k miles and allready the engine's been apart, he better be giving it to you for about $10 or $11k b/c about that one. I'd highly suggest a 2001 if possible.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. cluth problem??? transmission problem???? please HELP!!!
    By adamblake97 in forum Manual Transmission
    Replies: 3
    Last Post: 04-07-2014, 07:34 AM
  2. Obama's Woman Problem A Problem Of His Own Making
    By Ed Blown Vert in forum Political / Debate Forum
    Replies: 0
    Last Post: 01-14-2013, 02:50 PM
  3. Fuel Problem or Severe Engine Problem
    By pet_monk in forum General Help
    Replies: 3
    Last Post: 02-18-2008, 07:51 AM
  4. Electrical/charging problem problem
    By jchcomputers in forum General Help
    Replies: 4
    Last Post: 02-23-2007, 05:59 AM
  5. is it a clutch problem, or a tranny problem?
    By sgt0704 in forum Manual Transmission
    Replies: 3
    Last Post: 01-07-2007, 04:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •