Results 1 to 5 of 5

98 t/a idles high

This is a discussion on 98 t/a idles high within the General Help forums, part of the LSx Technical Help Section category; after it warms up it still idles at 1200 to 1500 anybody have any ideas not throwing any codes...

  1. #1
    Junior Member
    Join Date
    Jun 2008
    Location
    Butler mo
    Posts
    76

    Blue
    98 Trans Am

    98 t/a idles high

    after it warms up it still idles at 1200 to 1500 anybody have any ideas not throwing any codes

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Either a vacuum leak, a loose intake tract connection after the MAF, or a dirty IAC. Just a few possibilities. Check the PCV hose on the passenger side of the engine where it plugs in -- that litte hose tends to crack apart.

  3. #3
    Junior Member
    Join Date
    Jun 2008
    Location
    Butler mo
    Posts
    76

    Blue
    98 Trans Am

    whats the IAC and where is it

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    IAC = Idle Air Control valve -- it's on the side of the throttle body, has wires going to it. Adds and subtracts air from the intake charge at idle to hold the rpm where it needs to be.

  5. #5
    Junior Member
    Join Date
    Jun 2008
    Location
    Butler mo
    Posts
    76

    Blue
    98 Trans Am

    kinda looks like a valve with a rubber end thats supposed to open for fast idle and close for warm idle

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. so my 98 ls1 idles at about 1025 when warm.
    By goof4080 in forum General Help
    Replies: 15
    Last Post: 06-28-2010, 06:49 PM
  2. car idles better with tps sensor unplugged
    By occamaroz in forum Computer & Tuning
    Replies: 3
    Last Post: 11-03-2007, 04:09 PM
  3. idles then stumbles and dies!!!
    By huggerz28 in forum LT1
    Replies: 1
    Last Post: 03-19-2007, 10:49 PM
  4. !! help lt1 idles too high @ 1500 rpm !!
    By onemedina in forum General Help
    Replies: 2
    Last Post: 08-07-2006, 10:25 PM
  5. revs(idles)high after highway
    By JattGunMan in forum General Help
    Replies: 13
    Last Post: 05-03-2006, 11:00 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •