Results 1 to 6 of 6

95 Z28 runs rough when hot

This is a discussion on 95 Z28 runs rough when hot within the General Help forums, part of the LSx Technical Help Section category; ...

  1. #1
    Junior Member
    Join Date
    Jun 2007
    Location
    NE
    Posts
    2

    95 Z28 runs rough when hot

    I have a 95 z28 that has 100k on it. It runs great until it gets warmed up then starts to act like itís misfiring. Then if you step on it itíll clear up and run normal. Then occasionally the check engine light will come on. Then if after its warmed up and you shut it off then try to restart it it will turn over really slow and will start really hard.

    Any ideas?? Thanks to all that reply.

    Also my car is starting to eat serpentine belts. Is this a sign that the tensioner needs to be replace?? If so does anyone know where to get one???

  2. #2
    Senior Member 35thAnniZ28's Avatar
    Join Date
    Mar 2007
    Location
    Texas
    Posts
    1,809

    eating bulldog
    son of biscuit

    try going to auto zone and get the computer checked...might be a sensor malfunctioning

  3. #3
    Senior Member 35thAnniZ28's Avatar
    Join Date
    Mar 2007
    Location
    Texas
    Posts
    1,809

    eating bulldog
    son of biscuit

    check the spark plugs if their faulty or have carbon build up..if they do have build up...get carberator choke cleaner and a wire brush and clean them...

  4. #4
    Junior Member
    Join Date
    Jun 2007
    Location
    NE
    Posts
    2
    I'll check spark plugs. From what i've read it looks like it could be the MAF Sensor or optispark, even though the previous owner said the opti was replaced. I think i'm going to try to get the code read. All I have to do is drive it for about 5-10 minutes and it will start running rough and the check engine light will come on. It will stay on until I shut it off and let it cool down for a while.

    Does anyone know if you can rent a code reader from autozone or do you have to actually take the car there??

    Also about the serpentine belt, anyone have any ideas???

  5. #5
    Senior Member 35thAnniZ28's Avatar
    Join Date
    Mar 2007
    Location
    Texas
    Posts
    1,809

    eating bulldog
    son of biscuit

    oh...uhmm i might be wrong but the tensioner might be on too tight or too loose...thats probably why it might be "eating"up the belt.....check if the tensioner pulley has any jagged edges ...does it squeal at all?well i don't think they'll rent it ..but they should do it for you....hopefully some kid doesnt do it for you..i hate unexperienced kids who work at auto places...

  6. #6
    Junior Member
    Join Date
    Sep 2005
    Location
    Upstate NY
    Age
    36
    Posts
    50

    Green
    1996 Firebird Formula

    Sounds like bearing in tensioner.
    Last edited by LT1Gun; 06-27-2007 at 08:47 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 Black Z28 4 Sale! $8995
    By Black-LS1 in forum Vehicles For Sale / Trade
    Replies: 5
    Last Post: 03-16-2007, 09:23 PM
  2. Last chance and reduced - 99 Hugger Z28
    By Tucdog in forum Vehicles For Sale / Trade
    Replies: 4
    Last Post: 11-07-2006, 07:06 AM
  3. Engine running rough...need help
    By z28luvva in forum General Help
    Replies: 0
    Last Post: 10-25-2006, 10:37 AM
  4. 02 Z28 For Sale
    By z28badgirl in forum Vehicles For Sale / Trade
    Replies: 20
    Last Post: 12-27-2005, 05:03 AM
  5. Am i to hot?
    By 02' hawk in forum Forced Induction
    Replies: 26
    Last Post: 09-18-2005, 09:50 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •