Results 1 to 12 of 12

95 4.3 Blazer DD need help!

This is a discussion on 95 4.3 Blazer DD need help! within the General Help forums, part of the LSx Technical Help Section category; i have a 95 4.3 vortec v6 blazer driver gotta keep the miles off the maro...vechile sat for bout a ...

  1. #1
    Junior Member
    Join Date
    Jan 2007
    Location
    Cville,GA
    Posts
    25

    Silver and Black
    2002 Z-28 Camaro

    Question 95 4.3 Blazer DD need help!

    i have a 95 4.3 vortec v6 blazer driver gotta keep the miles off the maro...vechile sat for bout a year before i bought it its got 187000 miles on it and it ran great when i first had it my sister just got back from a trip to savannah,ga which put bout 500 miles on it and had no problems day after trip it starts running shitty sounding like the catalytic converter was shot cuz there was noise coming from the area and it just started smelling like sh*t. then it wouldnt run we replaced the coil and it starts now but still running bad. you can mash the gas and the rpms will jump and sputter from 900-1100 and thats bout all ya get...was thinkin bout replace the spark plug wires but i dunno im at a loss of what to do anybody out there with any ideas id appreciate it

  2. #2
    Junior Member
    Join Date
    Jan 2007
    Location
    Glendale az
    Age
    30
    Posts
    74
    Are you throwing a code? It sounds like a cat, but if ur throwing a code I'd look at the egr. Could also be a fuel problem. If you have the tools, I'd say vaccume test your egr, check the temp on your cat, and test your fuel pressure.

    It'll probably end up being the cat, but it would suck to buy a cat and have an exhaust shop put it on(or u put it on urself) and have it be something else.

  3. #3
    Junior Member
    Join Date
    Jan 2007
    Location
    Cville,GA
    Posts
    25

    Silver and Black
    2002 Z-28 Camaro

    well i was gonna just cut the damn cat off and weld a piece of exhaust piping in its place cuz theirs no emissons law for the area i live in. but a cat wouldnt cause it to run like that would it? guess ill try checkin the egr

  4. #4
    Junior Member
    Join Date
    Jan 2007
    Location
    Glendale az
    Age
    30
    Posts
    74
    an extremely clogged cat will make the motor run like shit... but won't throw a code. An egr will also make the car run like shit, but will throw a code. So is your check engine light on?

  5. #5
    Junior Member
    Join Date
    Jan 2007
    Location
    Cville,GA
    Posts
    25

    Silver and Black
    2002 Z-28 Camaro

    yes the check engine light is on it came on day or so later after the motor started running bad. would the egr make it just run bad all of a sudden? im going to check the cat tomorrow seeing as how their is noise coming from around the area where the cat is..buddy of mine totally denys there being any possibility its the cat but im tending to think it is

  6. #6
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    37
    Posts
    1,346

    black
    2002 WS6

    Yep egr would do it, had it happen on my Full size Jimmy, quick stop from speed, knocked some carbon loose and stuck the valve open. I'd dump the cats too happened on dads 92 suburban, wa that way from the factory.

  7. #7
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,468

    98 Formula
    06 duramax

    I've had a couple of 4.3's and still have a truck that has it. Piece of crap IMO but some people rave about them. Our 94 blazer had a problem with the EGR getting carbon in it. I took it off more than once and cleaned it. Easy to do and if memory serves me correctly there were two part numbers for that EGR and the one I needed was the expensive one so I would clean the old one when it needed it. Piece of cake to pull off and clean.
    I've also had ignition issues with my truck. Have you had the distributor changed out lately? The distributor base is plastic and extremely easy to crack when putting the cap back on. Ask me how I know. Another issue I've had is moisture getting under the wire on the coil. Seems my set of wires just don't seal tight to the coil so I loaded it up with dielectric grease and fixed that.
    I would really want to see what code you're getting. Could be anything from misfire codes to EGR pintle position to an O2 code. Pull that code and post back up what it is and maybe someone can put you on the right track.
    Being an OBD1 vehicle you can jump the pins with a paper clip and pull the codes yourself by counting the flashes the check engine light makes. I would have to look up the pins you jump because I don't know them right off hand. I *think* it's the upper 2 on the right of the connector but I would have to look it up. The light will flash and pause and flash again to give you the two digit code. An example is when it begins the diagnostic it flashes 12 which would be flash (pause) flash flash ( pause). It will cycle each code 3 times and finish with 12 again. Hope this helps and post back up with the code(s).

  8. #8
    Member
    Join Date
    Oct 2006
    Location
    Oklahoma City
    Posts
    282

    00 LS1, WS6, V8 Gremlin
    96 & 98 GTPs, 64 'Cuda

    Yes, the EGR on a 4.3 carbons up in no time, easy pull, easy clean.

    There was also an issue regarding the connector that goes to the coil. Firsthand I've experienced the strangest symptoms, replaced the coil to have it run OK then fizz out shortly thereafter. GM has a TSB out on it but in essence you just replace the connector.

  9. #9
    Junior Member
    Join Date
    Jan 2007
    Location
    Glendale az
    Age
    30
    Posts
    74
    Quote Originally Posted by RidinDirty View Post
    yes the check engine light is on it came on day or so later after the motor started running bad. would the egr make it just run bad all of a sudden? im going to check the cat tomorrow seeing as how their is noise coming from around the area where the cat is..buddy of mine totally denys there being any possibility its the cat but im tending to think it is
    listen to your buddy. Your cat won't throw a code. Get yourself a 10mm socket, a wratchet, and a can of carb/choke cleaner and clean that bitch out. Now if that doesn't work you're going to have to replace it... but thats just the way life is sometimes.

  10. #10
    Junior Member
    Join Date
    Jan 2007
    Location
    Cville,GA
    Posts
    25

    Silver and Black
    2002 Z-28 Camaro

    well it turned out to be the egr after all...not the easiest thing to pull out i actually ended up disconnecting the radiator hose from the thermostat cuz it was in the way and the bracket the throttle cable runs through but once i undid the 2 bolts it was just and easy clean up. changed the pcv and ica valves while i was at it cuz they were both pretty dirty and worn and aint bout 3-5 bucks a pop. SES light is off...probaly cuz i disconnected the battery when i changed out the coil but shes back running great even with 187000 miles thanks everybody for the help.

  11. #11
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,468

    98 Formula
    06 duramax

    Glad you got it. I hope you remember how to do it because you'll be back under there cleaning it again in the near future. Welcome to the world of the 4.3
    Did you look and see if you have the infamous intake leak down the front of the motor? I've had 2 4.3's and both had the lower intake gasket leak. I just pulled the intake on my 97 and replaced the gasket this summer. Now that was a fun job.

  12. #12
    Junior Member
    Join Date
    Jan 2007
    Location
    Cville,GA
    Posts
    25

    Silver and Black
    2002 Z-28 Camaro

    nope didnt see if there was a leak but the right valve color leaks oil the same as my buddys 95 s10 did nothin major its just oiled up while the other is clean but i looked at getting and after market edelbrock intake would that eliminate the egr? they offer them with egr and without egr?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •