Results 1 to 10 of 10

94 z28 won't start..

This is a discussion on 94 z28 won't start.. within the General Help forums, part of the LSx Technical Help Section category; So, I was pulling out of my driveway and my car died, I haven't been able to start it since. ...

  1. #1
    Junior Member
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    4
    1994 z28

    94 z28 won't start..

    So, I was pulling out of my driveway and my car died, I haven't been able to start it since. It turns fine, but it won't fire up. I thought it was the coil, but replaced that, as well as the battery and it still has the same problem.. Any Idea's as to what's wrong with it?

  2. #2
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    First check to see if it has spark. Then you can check fuel next. How many miles on it?

  3. #3
    Senior Member
    Join Date
    May 2009
    Location
    Toronto
    Posts
    1,083

    SOM
    2002 SS

    If it turns why did you replace the battery? How long was the car sitting? Sounds like it could be the optispark failing

  4. #4
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    try swaping with the fuel pump relay with the horn relay.

  5. #5
    Junior Member
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    4
    1994 z28

    Quote Originally Posted by bigrondownhiller View Post
    First check to see if it has spark. Then you can check fuel next. How many miles on it?
    It has spark..how do I check fuel? 164k

  6. #6
    Junior Member
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    4
    1994 z28

    Quote Originally Posted by 5abivt View Post
    If it turns why did you replace the battery? How long was the car sitting? Sounds like it could be the optispark failing
    Cause the battery needed replacing any way.. its been sitting about 2 weeks now. how do I check if it's the optispark? I have spark at least as far as the plug wires

  7. #7
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    You can rent a fuel pressure gauge from the auto parts store. Do you hear the fuel pump prime when you turn the key to on?

  8. #8
    Junior Member
    Join Date
    Dec 2009
    Location
    Germany
    Posts
    4
    1994 z28

    Quote Originally Posted by bigrondownhiller View Post
    You can rent a fuel pressure gauge from the auto parts store. Do you hear the fuel pump prime when you turn the key to on?
    Yeah, I hear it prime..and I tried spraying starter fluid in, and it didn't start.. so I'm thinking not a fuel problem?

  9. #9
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Next I would pull a couple of plugs then. What do they look like? Do they smell like raw fuel?

  10. #10
    Junior Member 95ZR28's Avatar
    Join Date
    Apr 2010
    Location
    Allen, Texas
    Posts
    9

    White w/blue pearl
    1995 Camaro ZR28

    Won't start

    I had the same problem with my 95z m6, I replaced the fuel pump, filter, relay, injectors, coil, and control module hoping that it wasn't the Opti. I was WRONG... I am in the process of replacing the opti and going coil on plug like the LS guys. Fingers crossed, hoping it works..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: 97 TA won't start
    By ADAM-00SS in forum LT1
    Replies: 7
    Last Post: 07-08-2010, 04:13 PM
  2. Z28 won't start
    By flaggs_ls1 in forum General Help
    Replies: 4
    Last Post: 05-11-2008, 09:46 PM
  3. where to start?
    By Jane_says in forum Firebird / WS6
    Replies: 47
    Last Post: 02-25-2007, 09:14 PM
  4. Cold Start/Warm Start Problem
    By I'mLS1John in forum General Help
    Replies: 11
    Last Post: 02-23-2007, 08:11 PM
  5. Cold Start/Warm Start Problem
    By I'mLS1John in forum New Member Introductions
    Replies: 0
    Last Post: 02-22-2007, 06:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •