Results 1 to 9 of 9

416 Stroker LS3

This is a discussion on 416 Stroker LS3 within the General Help forums, part of the LSx Technical Help Section category; Ever since i did my LS3 swap on my 01 the car runs a little warmer than usual. It used ...

  1. #1
    Member Blue_01_Z28's Avatar
    Join Date
    Mar 2008
    Location
    Midland, TX
    Posts
    349

    Metallic Blue
    2001 Chevrolet Camaro Z28

    416 Stroker LS3

    Ever since i did my LS3 swap on my 01 the car runs a little warmer than usual. It used to ride right at 210 now it goes about half way to the next marker. I'm guessing about 220-225. It doen't over heat to where the temp becomes uncontrollable but it does bother me running that hot. I havent changed the thermostat for a cooler one. I checked my fans that both are working. Next thing would be would i need a bigger radiator. Has anyone fixed this by just changin the thermostat or flushing the radiator? In general i know I have increased the power output with the same cooling system but wouldn't you all agree that 20HP = 20Hp which is about what a car is producing while cruising at 70 Mph. i could see it getting hotter when i stomp it but cruising?
    I did manage to drop the temp by turning on my heater full blast that brought it down to 210. But it was a hot ride from EL Paso to Midland!!!

  2. #2
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    Quote Originally Posted by Blue_01_Z28 View Post
    Ever since i did my LS3 swap on my 01 the car runs a little warmer than usual. It used to ride right at 210 now it goes about half way to the next marker. I'm guessing about 220-225. It doen't over heat to where the temp becomes uncontrollable but it does bother me running that hot. I havent changed the thermostat for a cooler one. I checked my fans that both are working. Next thing would be would i need a bigger radiator. Has anyone fixed this by just changin the thermostat or flushing the radiator? In general i know I have increased the power output with the same cooling system but wouldn't you all agree that 20HP = 20Hp which is about what a car is producing while cruising at 70 Mph. i could see it getting hotter when i stomp it but cruising?
    I did manage to drop the temp by turning on my heater full blast that brought it down to 210. But it was a hot ride from EL Paso to Midland!!!
    have you checked your coolant levels???

  3. #3
    Member Blue_01_Z28's Avatar
    Join Date
    Mar 2008
    Location
    Midland, TX
    Posts
    349

    Metallic Blue
    2001 Chevrolet Camaro Z28

    Quote Originally Posted by Spaz View Post
    have you checked your coolant levels???
    yup

  4. #4
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    I've read of people installing the heater hoses on the wrong connection at the water pump and the engine running warm. Is that possibly your issue?

  5. #5
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    The temp gauges aren't all that accurate either on 01/02's. Have you tried to verify by a different means the actual temperature?

    From what I understand, the gauges for those years are basically there to read cold/warm/hot. The earlier gauges were more accurate.

  6. #6
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Has the car been tuned since the swap? If not, have a tuner make some adjustments to the cooling programming to reduce the temps for the fan to kick on.

  7. #7
    Member Blue_01_Z28's Avatar
    Join Date
    Mar 2008
    Location
    Midland, TX
    Posts
    349

    Metallic Blue
    2001 Chevrolet Camaro Z28

    Quote Originally Posted by Cutlass View Post
    I've read of people installing the heater hoses on the wrong connection at the water pump and the engine running warm. Is that possibly your issue?
    Hmmm hadn't heard about that but I'm not perfect by any means, I guess I could have mixed them up. How about a pic of how they go? That would help me check. As for the tuning I can use my efi live to kick the fans on sooner. What I don't understand is that it just started doing that. The sensor may be a possibility, I have a spare one I could use. Also other than an infrared gun how do I get an accurate temp reading.

  8. #8
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    i believe they are different sizes so it would be hard to misinstall them. It looks like the front hose on the water pump goes to the passenger side connection on the heater core.

    The scan data on EFILive should be pretty accurate to the actual coolant temp. Otherwise you'd probably have to get a separate coolant temp gauge setup

  9. #9
    Member Blue_01_Z28's Avatar
    Join Date
    Mar 2008
    Location
    Midland, TX
    Posts
    349

    Metallic Blue
    2001 Chevrolet Camaro Z28

    Quote Originally Posted by Cutlass View Post
    i believe they are different sizes so it would be hard to misinstall them. It looks like the front hose on the water pump goes to the passenger side connection on the heater core.

    The scan data on EFILive should be pretty accurate to the actual coolant temp. Otherwise you'd probably have to get a separate coolant temp gauge setup
    I agree about it being hard to misplace parts on these cars. Everything is a different clip and or size so that you can't misplace parts.
    As for the EFI Live temp deal. Won't that give me the same temp, I mean it does pull the info from that temp sensor.
    Thanks for the input.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: 6.0 stroker
    By speeedo in forum Internal Engine
    Replies: 6
    Last Post: 03-19-2008, 02:43 AM
  2. Stroker q
    By grandkodiak in forum LT1
    Replies: 12
    Last Post: 02-28-2008, 09:53 PM
  3. Stroker kit on LS1?
    By Wheeler99WS6 in forum Internal Engine
    Replies: 25
    Last Post: 03-24-2007, 08:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •