Results 1 to 2 of 2

2001 TA Horn not working

This is a discussion on 2001 TA Horn not working within the General Help forums, part of the LSx Technical Help Section category; The horn in my 2001 Trans Am doesnt work at all anymore. Before it was random but now when I'm ...

  1. #1
    Junior Member
    Join Date
    Apr 2006
    Location
    Richardson
    Age
    41
    Posts
    3

    NBM
    01 TA

    2001 TA Horn not working

    The horn in my 2001 Trans Am doesnt work at all anymore. Before it was random but now when I'm pressing on the steering wheel, nothing. I'm guessing theres a loose wire or something. When I use the keyless remote there is no beep either. When I press the horn or turn off/on the keyless remote I can hear a click in the engine bay but no horn noise. Where should I go about looking for the problem? The fuse and relay is good. Thanks!

  2. #2
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    the horn is located in front of the passenger tire inside the bumper. most likely they are bad.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 F-Body LS1 Intake question
    By OutToWinPAHC in forum General Help
    Replies: 4
    Last Post: 10-19-2006, 01:59 PM
  2. Replies: 0
    Last Post: 07-17-2006, 08:42 AM
  3. 2001 SOM WS6 TA 6-Speed
    By 2001 SOM WS6 1969 GTO in forum Vehicles For Sale / Trade
    Replies: 4
    Last Post: 05-29-2006, 06:40 PM
  4. 2001 Production # Break Down
    By LIVINGTHEDREAMLIFE in forum Firebird / WS6
    Replies: 6
    Last Post: 05-15-2006, 05:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •