Results 1 to 16 of 16

2000 Z28....wont start

This is a discussion on 2000 Z28....wont start within the General Help forums, part of the LSx Technical Help Section category; My camaro stranded me recently. I went to lunch and came out to go back to work and it wouldnt ...

  1. #1
    Junior Member
    Join Date
    Aug 2005
    Location
    kansas city
    Age
    36
    Posts
    7

    White
    2000 Z28

    2000 Z28....wont start

    My camaro stranded me recently. I went to lunch and came out to go back to work and it wouldnt start at all. I put in the key and i get all the dash lights and radio comes on, then i turn the key and nothing.....no clicks or any other types of noises. I just replaced the starter in january, battery is nearly new too with no corrosion. I even had a new key made because alot of things i saw on the web stated the passkey could have been worn down over time. So i know this is a problem that could have hundreds of causes, i'm just wondering if anyone else has ever experienced this and/or any ideas on what the issue might be. I appreciate any help you can give!!

    just some other quick info, car is a/t with 112k miles. never had any other issues before this. thanks again!

  2. #2
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    check alt. mine did the same thing and it was my alt

  3. #3
    3-Time F-Body Offender doozjamann's Avatar
    Join Date
    Apr 2008
    Location
    NC
    Posts
    1,365

    Pewter
    2000 SS Camaro

    Starter may be hung. Bang on it with a hammer or big wrench.

  4. #4
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Check all the fuses/relays. See if you can jump it.

  5. #5
    James Bond Spikito's Avatar
    Join Date
    Aug 2007
    Location
    Texas
    Age
    30
    Posts
    4,546

    2001 3.8 Black - sold
    2000 SS Black M6

    does it have gas in it?

  6. #6
    OOHHH YEAH! jray0305usa's Avatar
    Join Date
    Apr 2008
    Location
    toledo ohio
    Age
    31
    Posts
    253

    black
    99 z28 a4

    ill it start in neutral? neutral safety switch bad?...

  7. #7
    Go Wings!! cmy99ss's Avatar
    Join Date
    Jul 2006
    Location
    Romeo, Mount Pleasant Michigan
    Age
    31
    Posts
    40

    Black
    1999 Camaro SS

    Yeah this just happened to my jeep wrangler over the winter and like jray0305usa said it was the NSS. There are ways to bypass it, not sure how on a Camaro but on my jeep it was easy. A 4/12 inch lift helps when working on anything under the car however. I ended up installing a push button start on the floor connected to the positive battery lead and the positive terminal on the starter and it starts perfect when I cant get it to start with the key. Now that its warming up though Im going to fix it correctly.
    1999 Camaro SS
    SLP LM exhaust and lid, BBK ssi intake manifold, BBK LT Headers, custom ORY pipe, Eibach drag launch kit, RAM PG clutch and flywheel, Vector tune

    351 RWHP 348 RWTQ

    Coming soon - Moser 12 bolt w/ 4.11 gear
    Livernois stage 2 heads with custom grind comp cam

  8. #8
    Go Wings!! cmy99ss's Avatar
    Join Date
    Jul 2006
    Location
    Romeo, Mount Pleasant Michigan
    Age
    31
    Posts
    40

    Black
    1999 Camaro SS

    by the way goodluck with whatever the problem is!

  9. #9
    Exalted Cyclops 67CamaroRSSS's Avatar
    Join Date
    Feb 2007
    Location
    San Diego, CA
    Posts
    5,824

    2002 Z28 A4 NBM
    Sadly now demodded :(

    VATS....

  10. #10
    Junior Member
    Join Date
    Aug 2008
    Location
    LOS ANGELES
    Posts
    66
    low battery starter solenoid or maybe the starter if you dont here no noises

  11. #11
    Member Joe00SS's Avatar
    Join Date
    Oct 2005
    Location
    CT
    Age
    46
    Posts
    465

    White Liquid Silver
    2000 Camaro SS/ 02 YZF-R1

    Quote Originally Posted by 67camarorsss View Post
    vats....
    .

    +1

  12. #12
    Your dealership guy konigandy6's Avatar
    Join Date
    Aug 2007
    Location
    Romeo, MI
    Posts
    6,557

    Velocity Yellow
    2008 Corvette Z06

    Quote Originally Posted by 67CamaroRSSS View Post
    VATS....
    +2

    Check your security system. It doesn't sound like a power issue.

    2008 Z06 - Velocity Yellow - OEM

    2017 Silverado Z71 5.3 - OEM

    2002 Z06 - Electron Blue Metallic - D1 - E85 - 701 rwhp 687 rwtq **sold**

    2002 Z28: M6 NBM - cam and boltons - 396rwhp 357 rwtq **sold**

  13. #13
    Member
    Join Date
    Oct 2008
    Location
    Miami, Fla
    Posts
    200

    Spiral Gray
    2004 Auto Corvette

    Smack the starter with a hammer mine did the same thing.

  14. #14
    Junior Member
    Join Date
    Apr 2009
    Location
    New Jersey
    Posts
    3

    Silver
    2000 Camaro Z-28

    Replace the ignition switch

  15. #15
    Member headpecker's Avatar
    Join Date
    May 2009
    Location
    columbus,oh
    Posts
    152

    siver
    2000 ss camaro

    Mine did that once,turned out to be corrosion on the ground cable-couldnt see it with the cable connected to the battery

  16. #16
    Junior Member JustOut4u's Avatar
    Join Date
    Apr 2009
    Location
    St. Louis MO
    Age
    36
    Posts
    24

    Blue
    99 Camaro Z28

    my guess is one of battery terminal worked themselves loose or is corroded, put a wench on it and see if you can tighten them. sometime they come just loose enough to have power and lights but wont handle the load of the starter.
    let us know

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: car wont start and now gauges wont work!
    By AB'sLs1 in forum General Help
    Replies: 52
    Last Post: 04-20-2013, 09:54 PM
  2. Help: help car wont start
    By dany3350 in forum General Help
    Replies: 18
    Last Post: 11-02-2012, 03:26 AM
  3. Help: wont start
    By red96 in forum General Help
    Replies: 6
    Last Post: 03-17-2011, 08:54 PM
  4. Car wont start
    By juiced99ws6 in forum General Help
    Replies: 3
    Last Post: 07-13-2007, 02:41 AM
  5. Replies: 8
    Last Post: 10-20-2006, 11:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •