Results 1 to 6 of 6

2000 WS6 erratic overheating

This is a discussion on 2000 WS6 erratic overheating within the General Help forums, part of the LSx Technical Help Section category; It's only happened 2 times so far. but I need to know what you guys think it could be? Whether ...

  1. #1
    Junior Member
    Join Date
    Oct 2005
    Location
    Las Vegas, NV
    Age
    37
    Posts
    19

    Black
    2000 WS6 Trans Am

    2000 WS6 erratic overheating

    It's only happened 2 times so far. but I need to know what you guys think it could be? Whether thermostat, water pump. or whatever Also When I turn the car off after driving anywhere. The Radiator makes a gurggling sound.

  2. #2
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    37
    Posts
    1,346

    black
    2002 WS6

    sounds like one of two things, your thermastat is getting stuck, or you are low low coolant, which would point to a leak. Under what conditions did it over heat?

  3. #3
    Junior Member
    Join Date
    Oct 2005
    Location
    Las Vegas, NV
    Age
    37
    Posts
    19

    Black
    2000 WS6 Trans Am

    I was driving pretty fast and it's pretty hot here in vegas. But it did it 2 weeks ago when I was driving normally at like 5 in the morning. So I'm gonna assume it's the thermostat. Should I go with the 180 or the 160. Is there a big difference?

  4. #4
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    37
    Posts
    1,346

    black
    2002 WS6

    The gurguling tells me that you may be low on coolant,but the thermastat would be a good start, I would stick with the 180 unless you plan on getting the fans programed turn on sooner. Check the level in the radiator by removing the the cap, it should be just at the bottom of the neck. You may also have a cap that is going bad and isn't keeping the proper pressure on the cooling system, I would replace that first, befoer the expence of a t-stat

  5. #5
    Junior Member
    Join Date
    Oct 2005
    Location
    Las Vegas, NV
    Age
    37
    Posts
    19

    Black
    2000 WS6 Trans Am

    well just to make sure it wasn't low I topped it off and it still gurggles. I'll replace the cap and see what that does. thanks

  6. #6
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    caps fail very often. i pressure tested mine just for the hell of it, it didnt hold pressure, def. replace cap first.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •