Results 1 to 7 of 7

2000 Corvette LS1 in 66 GTO

This is a discussion on 2000 Corvette LS1 in 66 GTO within the General Help forums, part of the LSx Technical Help Section category; Currently putting an LS1 in a 66 GTO for a guy. Have installed an ECM and wiring harness reworked by ...

  1. #1
    Junior Member
    Join Date
    Oct 2011
    Location
    Paola, KS
    Posts
    3

    red
    37 Ford

    2000 Corvette LS1 in 66 GTO

    Currently putting an LS1 in a 66 GTO for a guy. Have installed an ECM and wiring harness reworked by Fuel Injection Connection into car. This equipment was provided by the owner but I did not get wiring diagrams or instructions. Have call FIC for help but no calls returned. At present have power at each coil and each fuel injector but no fire out of coils or fuel out of injectors.

    Any suggestions on where to start to trace out the problem?

    Thanks

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Yikes. Without schematics that is going to be one difficult job. Any idea what the ECM is out of originally, or is it a complete aftermarket engine controller? Nothing like seeing a company stand behind and support their product.

  3. #3
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    I took a look at their website and do not see any information on engine controllers or wiring. Looks like they only specialize in injectors.

  4. #4
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    well if its a 2000 Corvette ECM/wiring then each coil and injector are fired by a signal from the ECM. Most likely there is something wrong with the crankshaft position sensor or its wiring/connector. That would knock out both ignition and fuel injector drive.

  5. #5
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Info was in the title -- I read the post.

  6. #6
    Junior Member
    Join Date
    Oct 2011
    Location
    Paola, KS
    Posts
    3

    red
    37 Ford

    The ECM and harness are supposedly out of a 2000 Corvette and FIC did a revamp on the wiring so it could be used in earlier vehicles. The T56 trans is supposedly out of a Camaro of about the same year. You are correct, with no instructions and only the OEM schematic, which the color-coding on the injectors does not match, it is a bit difficult to trace the problem.

  7. #7
    Junior Member
    Join Date
    Oct 2011
    Location
    Paola, KS
    Posts
    3

    red
    37 Ford

    Their Website basically says nothing, no tech, just advertisement.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 ws6 vs c4 corvette
    By Leeroyws6 in forum Kill Stories
    Replies: 10
    Last Post: 10-04-2010, 04:32 PM
  2. 2000 Corvette
    By predator in forum Vehicles For Sale / Trade
    Replies: 5
    Last Post: 11-14-2007, 11:35 PM
  3. 2000 corvette
    By 99-SS-Conv in forum Corvette
    Replies: 5
    Last Post: 05-09-2007, 03:56 AM
  4. 2000 camaro ss vs 2000 corvette
    By 99-SS-Conv in forum General Help
    Replies: 11
    Last Post: 04-03-2007, 09:17 AM
  5. did the 2000 corvette have the ls6
    By XtinKt in forum External Engine
    Replies: 5
    Last Post: 01-26-2006, 01:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •