Results 1 to 6 of 6

2 questions

This is a discussion on 2 questions within the General Help forums, part of the LSx Technical Help Section category; i had my 02 ss in the garage for about a month because of snow and salt. i took it ...

  1. #1
    Junior Member 2000 ss's Avatar
    Join Date
    Dec 2006
    Location
    ny
    Posts
    48

    2 questions

    i had my 02 ss in the garage for about a month because of snow and salt. i took it out tonite and it feels slow like mushy. should i try dry gas?? also i heard ls1s idle rough but how rough is normal?

  2. #2
    Nitrous Tuner LS2Tuner's Avatar
    Join Date
    Aug 2006
    Location
    WestCoast AZ-CALI
    Posts
    4,763

    Silver
    05 Goat SMASHED

    How much gas was in it when parked???? It should NOT of went bad in only a month in the cold.
    It idles rough non stop now...?
    Don't be afraid of the bottle!!! Be afraid of your tune!!!

  3. #3
    Junior Member 2000 ss's Avatar
    Join Date
    Dec 2006
    Location
    ny
    Posts
    48
    i had a half a tank of gas. it has always idled rough. i did full tune up car has 42,000 miles.

  4. #4
    Nitrous Tuner LS2Tuner's Avatar
    Join Date
    Aug 2006
    Location
    WestCoast AZ-CALI
    Posts
    4,763

    Silver
    05 Goat SMASHED

    I'd add some Restore to take out any more moisture that is in the tank.

  5. #5
    Member
    Join Date
    Oct 2005
    Location
    calif.
    Posts
    213
    I would say the stock LS1 idles really smooth compared to the earlier GM small blocks---The new firing order really helped in smoothing out the idle--I would think you have another small issue such as an injector going away--or if it is really bad it can be an ignition misfire and could be a bad coil-plug-or wire----

    I have a smallish .221 cam @ 114 and it idles smooth at 750 RPM's can't even tell it's in there......

  6. #6
    Member jmhvenom's Avatar
    Join Date
    Oct 2005
    Location
    Cincinnati, OH
    Age
    31
    Posts
    821

    Silver
    2002 Z28

    I had my cam sitting our in the cold for the whole winter in Cincinnati. Only snowed and was freezing for about a month, but it sat under a bunch of ice and it is going just fine. Stock they do not really idle too rough. Would look into some of the things suggested already by the guys.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vert Questions
    By sunset solar in forum General Help
    Replies: 1
    Last Post: 11-13-2006, 04:20 PM
  2. Wheels and tires questions
    By Daniel P. in forum Wheels and Tires
    Replies: 5
    Last Post: 06-19-2006, 06:09 AM
  3. Some questions about Suspension mods
    By white01ws6 in forum Western Members
    Replies: 6
    Last Post: 11-08-2005, 02:42 PM
  4. Install questions, please help!
    By RAWPWR3 in forum General Help
    Replies: 5
    Last Post: 11-04-2005, 05:37 PM
  5. Few questions about Suspension mods
    By white01ws6 in forum Suspension and Handling
    Replies: 3
    Last Post: 10-27-2005, 01:31 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •