Results 1 to 2 of 2

1999 Trans Am not starting.

This is a discussion on 1999 Trans Am not starting. within the General Help forums, part of the LSx Technical Help Section category; I bought a 99 TA with the broken starter mount issue. It supposedly was a rebuilt engine(it is clean with ...

  1. #1
    Junior Member
    Join Date
    Sep 2012

    Navy Blue Metallic
    2000 Z28

    1999 Trans Am not starting.

    I bought a 99 TA with the broken starter mount issue. It supposedly was a rebuilt engine(it is clean with all new gaskets, and some sensors) Guy I got it from said he thinks he didnt tighten starter all the way and was spinning it over after installing engine and block broke. I had the starter area on block fixed and installed the truck starter.(I have a guy local to me that did an AWESOME job Tig welding the block in the car). I have a 2000 Z28 that I have owned since it had 3 miles on it, but have never ANY issues out of it so I'm kind of a rookie at something this involved on a LS car. I have spark, injector pulse, strong fuel pressure at the rail(don't know psi but it comes out strong) Car cranks over fine and has 120-180 psi on all cylinders(kinda low on a few,but engine has never been ran, and it should fire with at least 100) I have checked to make sure cam and crank sensors are plugged in as well. I am at a loss. Any thoughts? Not really new to the site but its been long enough I could not remember my user name.

  2. #2
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Ugy Lower Corner of AL

    Navy Blue Metallic
    98 T/A w/a little mods...

    Glad you were able to fix the starter block.

    Fuel, Air, Spark, Tune....these are the 4 things need for a fuel injection engine to run.

    Fuel - You've checked the fuel pressure, but have you checked the injectors (FI)? FI's can fail because of electrical issue (no pulse to inject fuel) or fuel flow issue (bad injector, gunked up from sitting, etc..) Point being - they need to be checked too.

    Air - simple

    Spark - Seems you've already check this area.

    Tune - You said it was rebuilt, was it rebuilt by him or a shop? I put this here because if the timing chain is incorrectly installed then your timing could be completely off. This effects the the PCM.

    Can you shoot a video of it trying to start and post it? This could help a lot.

    Also where in AL are you?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Trans Am WS6 Not Starting
    By Blackhawk96 in forum LT1
    Replies: 7
    Last Post: 05-19-2013, 11:24 PM
  2. Trans am Starting issue, Fuel Pressure Regulator?
    By mrfriendly23 in forum General Help
    Replies: 4
    Last Post: 04-13-2010, 06:26 PM
  3. Replies: 0
    Last Post: 09-29-2007, 06:50 AM
  4. 1999 Pontiac Trans Am SLP Performance Parts Test - Trans Slam
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 0
    Last Post: 08-29-2007, 03:10 AM
  5. my 1999 Trans Am
    By tals199 in forum Member's Rides
    Replies: 12
    Last Post: 11-09-2005, 06:13 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts