Results 1 to 6 of 6

1998 Z28 Stalls After hour Drive and hard to start

This is a discussion on 1998 Z28 Stalls After hour Drive and hard to start within the General Help forums, part of the LSx Technical Help Section category; Hey everyone new to forums and had a question about my new to me z28. After about an hour of ...

  1. #1
    Junior Member
    Join Date
    Nov 2011
    Location
    s
    Posts
    3

    Red
    1998 z28

    1998 Z28 Stalls After hour Drive and hard to start

    Hey everyone new to forums and had a question about my new to me z28. After about an hour of driving it will stall when its hot its worse as i am driving it feels great i will come to a random stop and the idle will flicker to 500 rpm then the car will die out i will try to restart it and it will not start unless i let it sit for a minute or 2 then start it back up then it will die again when i come to stop at high rpm runs like a dream but idle will not hold and its random and if i try to give it throttle while trying to start it just floods it to hell.I flushed the system with seafoam and bought a new air filter nothing no change error codes its spitting out is for 02 sensors do to my off road pipe but thats it so i brought it to chevy to see what they said it was they told me it was the fuel pump i went to change it today and some one had already cut the door panel in the trunk and replaced it with a brand new walbro and the fuel filter is brand new as well so the last owner tried to fix this problem and couldn't its a great car trying to find out what it may be was thinking it may be the IAC but wld it still give me issues if i was giving it throttle while trying to start it?Any help or insight to this issues wld be appreciated thanks.

  2. #2
    Drop&Drag matt evans's Avatar
    Join Date
    Jan 2010
    Location
    clyde nc
    Posts
    287

    black
    02 Z28 and 00 SS

    Might be your crankshaft position sensor fixing to shit on you. mine when it would get hot would shut the car down and take about an hour to crank back. $50 part and about 15 min work. advance usually keeps them in stock.

  3. #3
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    ^^ Could very well be this. However, before you go swapping out parts -- let's do some diagnostics. Did you check fuel pressure? You should have around 58 psi at the rail. Did you scan it for codes recently, including pending codes? I understand that your SES light is on due to your ORY, however, codes can be set at any time. Also, pending codes will show a fault that is in process that has not yet caused the SES to be set until they happen two or more times within a certain number of run cycles. Is your throttle body dirty? This can cause idle issues and difficulty starting, especially if the idle air control valve is gunked up. Let us know what you find.

  4. #4
    Retired NOT tired SteveC's Avatar
    Join Date
    Jul 2005
    Location
    Poway, Ca
    Posts
    1,126

    SOM
    2001 Z28 (Sara)

    When was the inline fuel filter replaced?

    SteveC

  5. #5
    Drop&Drag matt evans's Avatar
    Join Date
    Jan 2010
    Location
    clyde nc
    Posts
    287

    black
    02 Z28 and 00 SS

    Quote Originally Posted by pajeff02 View Post
    ^^ Could very well be this. However, before you go swapping out parts -- let's do some diagnostics. Did you check fuel pressure? You should have around 58 psi at the rail. Did you scan it for codes recently, including pending codes? I understand that your SES light is on due to your ORY, however, codes can be set at any time. Also, pending codes will show a fault that is in process that has not yet caused the SES to be set until they happen two or more times within a certain number of run cycles. Is your throttle body dirty? This can cause idle issues and difficulty starting, especially if the idle air control valve is gunked up. Let us know what you find.
    In all my expierence so far with my ORX i removed the cats and just put the rear o2s back in line and ive not had a SES light come on at all and i check it regualry for pending o2 codes. Crankshaft position center wont throw any codes to the CPU, least in my expierence it didnt.

  6. #6
    Junior Member
    Join Date
    Nov 2011
    Location
    s
    Posts
    3

    Red
    1998 z28

    Thanks for all your replies every piece of the puzzle u guys find helps me out more lol need to get this thing sorted out so i can use it to go to work killin me.My 02 sensor code is on due to the last guy cutting the 02 sensor lines and just plugging in the 02 sensors to patch the holes not sure what he was thinking lol gonna fix that when i get the simulators .i have done the codes a hundred times even while car is doing its stalling performance all returned is only 02 sensor errors.I just replaced the fuel filter and fuel pump even though last guy tried to fix it this way obviously due to his hack job in the trunk tin snips not the way to go on that BTW i would always use a grinder or cutting wheel cause now i have to clean up his wonderful work.Have to wait for replacement out line for fuel tank damn O rings fell apart then i will know if fuel pump fixed it i doubt it though..Its probably the CPS or the Ignition Relay i would think because on the freeway it screams even while its having stalling issues at idle i would think fuel pump would hesitate when ur ripping on it at high speed never seen one only die at idle and be completely random but stranger stuff has happened.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Exteral hard drive help
    By Pitchlock in forum Almost Anything Goes
    Replies: 0
    Last Post: 04-17-2010, 08:18 PM
  2. need a new hard drive
    By 1MileCrash in forum Computers / Gaming
    Replies: 11
    Last Post: 11-09-2009, 07:40 AM
  3. Hard drive failure
    By grouch0jr in forum Computers / Gaming
    Replies: 12
    Last Post: 10-21-2009, 12:20 PM
  4. External hard drive
    By Soltakr in forum Computers / Gaming
    Replies: 16
    Last Post: 11-24-2008, 01:35 PM
  5. Hard drive problems please help :(
    By grandkodiak in forum Almost Anything Goes
    Replies: 3
    Last Post: 09-05-2006, 11:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •