Page 1 of 2 12 LastLast
Results 1 to 20 of 26
Like Tree1Likes

1997 Chevy Astro LQ4 Swap, Low Power

This is a discussion on 1997 Chevy Astro LQ4 Swap, Low Power within the General Help forums, part of the LSx Technical Help Section category; I swap a 03 LQ4 4L80E NP262 into my 97 Astro 5 years and since then i been trying to ...

  1. #1
    Junior Member
    Join Date
    Mar 2016
    Location
    Watertown, SD
    Posts
    14

    Green
    1997 Chevy Astro LQ4 4L80

    1997 Chevy Astro LQ4 Swap, Low Power

    I swap a 03 LQ4 4L80E NP262 into my 97 Astro 5 years and since then i been trying to figured out why it has no power at WOT. Cant seem to find a right answer on fuel pressure. ive tried different FPR no change, New Pump no change, New fuel rail and fuel filter and 25lb injectors still nothing.



    This video you can hear it bog down



  2. #2
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Has it been tune? (Tuned for the transmission?)

    LQ4's have 50 psi so it looks good.

    I see 25lb injectors are the stock injector for LQ4's. Have they been tested or are they new?


    Could be that you have a vacuum leak.

  3. #3
    Junior Member
    Join Date
    Mar 2016
    Location
    Watertown, SD
    Posts
    14

    Green
    1997 Chevy Astro LQ4 4L80

    Stock tune, with trans pressure up'd and torque management disabled. New injectors all been flow matched, no vac leaks

  4. #4
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Compression check?


    Any codes popping up?

  5. #5
    Junior Member
    Join Date
    Mar 2016
    Location
    Watertown, SD
    Posts
    14

    Green
    1997 Chevy Astro LQ4 4L80

    no codes, ill check comp, whats the range it should be around

  6. #6
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    should be around 180 psi.

    More importantly is that they all should be within 10-15 psi.

  7. #7
    Junior Member
    Join Date
    Mar 2016
    Location
    Watertown, SD
    Posts
    14

    Green
    1997 Chevy Astro LQ4 4L80

    Every Cly was 150

    oi67.tinypic.com/2mmhhr7.jpg

  8. #8
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Any spark knock or other signs of it leaning out? Have you check the color on the plugs? What does the fuel pressure read under load?

  9. #9
    Junior Member
    Join Date
    Mar 2016
    Location
    Watertown, SD
    Posts
    14

    Green
    1997 Chevy Astro LQ4 4L80

    0 kr, pic in my last post, 65psi at wot

  10. #10
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    How many total miles on the LQ4?

    Cyl pressure kinda low, but good news is they are all the same. Try a wet reading next. Squirt a little oil in through the spark plug hole, turn motor over a few times and then see if the pressure rises.



    I've listen to the bottom video again and I'm not hearing anything, seems like it's healthy.



    Could it be in the tune or transmission? Shift points not quite right....

  11. #11
    Junior Member
    Join Date
    Mar 2016
    Location
    Watertown, SD
    Posts
    14

    Green
    1997 Chevy Astro LQ4 4L80

    Shift points were up'd too, I'll try wet, about 400k on the motor and trans.

  12. #12
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    400k.... :wow: Has it had a rebuild?

  13. #13
    Junior Member
    Join Date
    Mar 2016
    Location
    Watertown, SD
    Posts
    14

    Green
    1997 Chevy Astro LQ4 4L80

    Nope not yet, all original besides being swapped from my truck to van

  14. #14
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...





    I'm amazed you have compression......I'm willing to bet it's time for some new rings and at least a line hone, if not flat out a mild bore like .005"

  15. #15
    Junior Member
    Join Date
    Mar 2016
    Location
    Watertown, SD
    Posts
    14

    Green
    1997 Chevy Astro LQ4 4L80

    I've gone to 600k and still had comp, when I had the heads off to fix a valve you could still see the cross etching

  16. #16
    Junior Member
    Join Date
    Mar 2016
    Location
    Watertown, SD
    Posts
    14

    Green
    1997 Chevy Astro LQ4 4L80

    I think I'm finally getting somewhere, after last night letting it idle and watching sensors I noticed the map sensor didn't really change even after raving it. So I unplugged it and let it use the default settings for it and now when I get on, it takes off. So gonna order a new map, crank, and cam sensors all are still original

  17. #17
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Strange that it wasn't setting a code. If the MAP sensor is reading out of range the PCM will usually detect that and set a fault code.

  18. #18
    Junior Member
    Join Date
    Mar 2016
    Location
    Watertown, SD
    Posts
    14

    Green
    1997 Chevy Astro LQ4 4L80

    Sometimes, I've seen alot that don't till the finally fail

  19. #19
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Glad you think you found it. I was about to suggest checking the sensors.

  20. #20
    Junior Member
    Join Date
    Mar 2016
    Location
    Watertown, SD
    Posts
    14

    Green
    1997 Chevy Astro LQ4 4L80

    I'm hoping, this has bugging me for years and never been able to narrow it down

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1997 Z28 Camaro Door power Mirrors - $40
    By Chad97SS in forum Parts For Sale / Trade
    Replies: 13
    Last Post: 04-08-2009, 10:35 AM
  2. Help: 1997 Tahoe wants LS2 power
    By WackAssLife in forum General Help
    Replies: 3
    Last Post: 11-02-2008, 06:57 PM
  3. For Sale, 1997 Chevy S-10, 2002 Honda CBR F4i $11,000 OBO
    By ozmanxvi in forum Vehicles For Sale / Trade
    Replies: 3
    Last Post: 07-29-2006, 09:56 PM
  4. 1997 Extended Cab Chevy Z71
    By '99 SLP#24 in forum Vehicles For Sale / Trade
    Replies: 6
    Last Post: 05-23-2006, 06:24 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •