Results 1 to 14 of 14

04 LS1 engines in 98 trans am

This is a discussion on 04 LS1 engines in 98 trans am within the General Help forums, part of the LSx Technical Help Section category; looking at an Ls1 from a 2004 GTO and an LS1+4l60E from a 2003/2004 Corvette they both have 25-30k miles ...

  1. #1
    Junior Member
    Join Date
    Aug 2009
    Location
    Tampa Bay
    Posts
    73

    whote
    98 T/A RAM AIR

    04 LS1 engines in 98 trans am

    looking at an Ls1 from a 2004 GTO and an LS1+4l60E from a 2003/2004 Corvette they both have 25-30k miles on them and I need a new engine for my 98 Trans AM to replace my dead LS1 (oil ran dry) - what kind of compatibility issues am I going to face , are these a relatively easy swap? any details of difference I will have to deal with (ie pay for) are appreciated. Also, if anyone has a 400-500+HP engine for sale that will fit my 98 TA and mount up to my stock 4L60E tranny (automatic) let me know.

    Thanks in advance for all your much appreciated feedback.

    Sincerely,


    Tom Sullivan
    Ellenton, FL
    34222
    941-822-2015
    Last edited by bossho; 04-02-2010 at 02:43 PM.

  2. #2
    Member blackbird0230's Avatar
    Join Date
    Jul 2009
    Location
    Colorado
    Posts
    828

    Black
    2002 Trans am WS6 pkg

    Quote Originally Posted by bossho View Post
    looking at an Ls1 from a 2004 GTO and an LS1+4l60E from a 2003/2004 Corvette they both have 25-30k miles on them and I need a new engine for my 98 Trans AM to replace my dead LS1 (oil ran dry) - what kind of compatibility issues am I going to face , are these a relatively easy swap? any details of difference I will have to deal with (ie pay for) are appreciated. Also, if anyone has a 400-500+HP engine for sale that will fit my 98 TA let me know.

    Thanks in advance for all your much appreciated feedback.

    Sincerely,


    Tom Sullivan
    Ellenton, FL
    34222
    941-822-2015

    This is a great question. I'm lookin to buy a new motor so that I can pull the numbers matching motor and put it aside for future value. Let us know!

  3. #3
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    If I remember correctly, a GTO motor will fit with no hassle. I think it will run with your PCM as well. I could be wrong, but others will chime in on this one. You shouldn't have any issues.

  4. #4
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    it will work just fine... just got to remember to swap your oil pan on to the gto ls1...

  5. #5
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    you can also get a LS6 crate for relativly cheap now days... that is the route i went... i think i paid 3,400 for mine... direct swap in just changed over my oil pan...

  6. #6
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Quote Originally Posted by bossho View Post
    an LS1+4l60E from a 2003/2004 Corvette
    Corvettes have a torque tube between the engine and transmission and the rear diff is bolted to the back of the transmission, so that "Corvette" transmission won't work for you. The engine should though.

  7. #7
    Member blackbird0230's Avatar
    Join Date
    Jul 2009
    Location
    Colorado
    Posts
    828

    Black
    2002 Trans am WS6 pkg

    Quote Originally Posted by Spaz View Post
    you can also get a LS6 crate for relativly cheap now days... that is the route i went... i think i paid 3,400 for mine... direct swap in just changed over my oil pan...
    Not bad at all! I'll look into that.

    side note: I wish they designed our transmissions like the corvette so we could get some weight off the front......

  8. #8
    Junior Member buiick's Avatar
    Join Date
    May 2010
    Location
    delaware
    Posts
    12

    silver
    2001 Firebird Formula LS1

    can someone help me out I bought a motor from a 1998 t/a to replace the one in my 2001 firebird and now it wont fire any of the coils on the passanger side! i do have injector pulse though ? any in put

  9. #9
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    Quote Originally Posted by buiick View Post
    can someone help me out I bought a motor from a 1998 t/a to replace the one in my 2001 firebird and now it wont fire any of the coils on the passanger side! i do have injector pulse though ? any in put
    are they plugged in to the harness???

  10. #10
    Junior Member buiick's Avatar
    Join Date
    May 2010
    Location
    delaware
    Posts
    12

    silver
    2001 Firebird Formula LS1

    yes for sure all is plugged in and power to the low ref. but no signal to fire the coils? is there a difference between the 98 motor to the 2001?

  11. #11
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    I read in GMHTP that if you put a newer motor in an older car, you must use the BCM and key from the donor car. Without those, you will not fire. Your VATS might be activating.
    Last edited by cammed goat; 05-18-2010 at 05:17 PM.

  12. #12
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    cam sensor is different I think
    Read this Thread

  13. #13
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Quote Originally Posted by Cutlass View Post
    cam sensor is different I think
    Read this Thread
    Ah. So it's not as complicated as I thought. Good to know.

  14. #14
    Member
    Join Date
    Mar 2007
    Location
    NC
    Posts
    421

    NBM
    1998Z28

    Just remember that you need to reuse your water temp sensor off your 98 motor. Its got 3 wires oposed to 2 on the later models.
    TSP 347 SB, TSP Stage 2.5 PRC LS6, TSP MS4, Performabuilt Stage 2 4L60E, Yank PT4000, 4.11s, Fast 90/90, FTRA Cold air intake+all the free mods, Dynatech Supermaxx Exaust System, DMH Cutouts, Hooker Catback/FTRA Tips. Tuned by RPM/Garner NC. 11.28@119

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Engines
    By 024mula in forum LS2/LS3/LS4/LSx
    Replies: 9
    Last Post: 11-29-2012, 07:21 PM
  2. LS2 And LS7 Engines - Gen Four
    By Ed Blown Vert in forum Almost Anything Goes
    Replies: 0
    Last Post: 12-18-2009, 10:40 AM
  3. old new guy to Ls engines
    By 2001 383 Z28 in forum New Member Introductions
    Replies: 1
    Last Post: 06-08-2009, 12:16 PM
  4. New to LS Engines, have some ?'s
    By RCcola55 in forum General Help
    Replies: 6
    Last Post: 03-09-2009, 06:50 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •