Results 1 to 6 of 6

02 sensors

This is a discussion on 02 sensors within the General Help forums, part of the LSx Technical Help Section category; I have a 99 SS which has the back 02 sensors turned off. According to Auto Zone and their scanner, ...

  1. #1
    Junior Member
    Join Date
    Oct 2008
    Location
    Payson, Az
    Posts
    12

    pewter
    1999 Camaro SS

    02 sensors

    I have a 99 SS which has the back 02 sensors turned off. According to Auto Zone and their scanner, my front left sensor is not working. Is it better to replace both sides, or is just replacing the bad one good enough?

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Umm If its "not Working" than you can just replace that sensor. What code did it throw or is it throwing?
    If you still have the rear sensors they will work up-front.
    J
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    Junior Member
    Join Date
    Oct 2008
    Location
    Payson, Az
    Posts
    12

    pewter
    1999 Camaro SS

    The scanner said that the bank 1 front was the bad sensor. I don't remember what the code was. I took the rear left sensor and put it up front but that did not turn the check engine light out. Maybe the rear was also bad.

  4. #4
    TunedbyFrost.com Tuner Frost's Avatar
    Join Date
    Jul 2007
    Location
    Richmond VA
    Posts
    2,415

    LS1.com Sponsor
    GM Tuner

    I usually recommend replacing them as a pair. As they age, they wander off. There will definitely be a left/right imbalance replacing just one. If you have headers, they need to be changed every 15K miles. They will be bad long before they set codes. When they wander off, so does your fuel economy and part throttle fueling.

  5. #5
    Junior Member
    Join Date
    May 2009
    Location
    minot, nd
    Posts
    9

    white
    1998 camaro Z28

    after you replace the sensor you have to get the code cleared the back txo sensors doesn't matter. i have long tube headers all i had to do is get bypass sensor they are 24 dollars a pair.

  6. #6
    Junior Member
    Join Date
    Oct 2008
    Location
    Payson, Az
    Posts
    12

    pewter
    1999 Camaro SS

    When you mentioned by-pass sensors, is that for the back sensors that were turned off? The threaded hole on the right back position is stripped. Can I just have both post cat sensor threaded holes welded shut.
    Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. O2 sensors
    By c5z28 in forum Computer & Tuning
    Replies: 27
    Last Post: 10-06-2010, 02:35 PM
  2. O2 sensors
    By Soltakr in forum External Engine
    Replies: 19
    Last Post: 05-20-2008, 10:09 PM
  3. 02 sensors
    By 02sscamaro in forum General Help
    Replies: 25
    Last Post: 04-16-2008, 05:02 AM
  4. o2 sensors
    By ls1_02 in forum General Help
    Replies: 9
    Last Post: 01-10-2008, 09:51 AM
  5. Should I buy new sensors?
    By EastTNZ28 in forum General Help
    Replies: 0
    Last Post: 06-15-2007, 10:14 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •