Results 1 to 8 of 8

02 sensor???? maybe???

This is a discussion on 02 sensor???? maybe??? within the General Help forums, part of the LSx Technical Help Section category; Ok so here is what's going on, a few days ago I was driving and a SES light came on. ...

  1. #1
    Member
    Join Date
    Apr 2010
    Location
    Michigan
    Posts
    165

    Silver
    02 Pontiac

    02 sensor???? maybe???

    Ok so here is what's going on, a few days ago I was driving and a SES light came on. On the way to the part's store already I figured that I would have it checked. They told me it was a 02 sensor. Since than I noticed that the SES light went out. Thinking OK well that was a bit strange I continued to drive but didn't do anything. Two day's ago the SES light again came on. This time I disconnected that battery in hopes to re-program the computer. Well it seemed to have worked for a short time, but the SES light came on again while I was driving home last night. It has since went out after my girl drove it to the store today..... anyone have a clue on what's going on???

  2. #2
    Stockitie Stock Stock 95camaroZNC's Avatar
    Join Date
    Jun 2008
    Location
    Raleigh NC
    Age
    30
    Posts
    897

    Red
    1999 Trans Am

    One of your cats might be going bad? Did they tell you which sensor it was? My advice is to take it to a auto zone or anything like that and they can tell you which it is. Does it shake or sputter when the lights on?

  3. #3
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Agree, Prolly should take it back in and have the issue pinpointed first, especially b4 throwing any parts @ it..
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  4. #4
    Member 20ws6speed01's Avatar
    Join Date
    Jun 2009
    Location
    Winston,OR
    Posts
    272

    blue
    2001 WS6

    when ur car has or see's "GOOD trips" it will turn off SES lite BAD trips turn on lite..Recommend replace both up & down stearm O2 sen because 1 new & 1 old may mess w/PCM

  5. #5
    Member
    Join Date
    Nov 2006
    Location
    clarinda
    Posts
    144

    Black
    1998 firebird formula ws6

    i Had that same problem and the code said both sides and i replaced them yestraday, the two front ones where burnt, i had frost delete my back ones out so i just swaped, it made a big difference on mine, also on the driver side front one the wires must have touched the motor and it burned some of the wires? Mine spurded and 1500 rpm and 2000 tho?

  6. #6
    Member DaddySS's Avatar
    Join Date
    Oct 2005
    Location
    Bergen Co. NJ
    Posts
    590

    Black
    2000 Camaro SS Conv.

    get the code numbers and post them up.

  7. #7
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,466

    Red
    02 35th LE Camaro SS

    Quote Originally Posted by DaddySS View Post
    get the code numbers and post them up.
    ^This

    Don't do anything until you post your codes. Lots of things can trip a SES light and usually the people at places like Autozone are idiots...no offense to anyone working at a parts store..but at the ones around here they read the codes and feed you a bunch of shit.

    Post your codes so we can tell you what to do.

  8. #8
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    Quote Originally Posted by 20ws6speed01 View Post
    when ur car has or see's "GOOD trips" it will turn off SES lite BAD trips turn on lite..Recommend replace both up & down stearm O2 sen because 1 new & 1 old may mess w/PCM
    the way this works is there are certain criteria and conditions that have to be met before it'll set the DTC Normally it's other DTC's that are or aren't on among certain engine conditions such as the car being in closed loop and the load condition the car is under . In order for the light to clear there are a number of ignition cycles (most O2 codes it's 3 cycles) that the car has to go through without the DTC being set before it'll turn the light off. So there's really no good trip bad trip. There are also 2 upstream and 2 down stream sensors that are independant of one another so replacing the upstream or downstream sensors really have no relation to each other.


    To the original poster......posting the actual code number would be a ton of help. Those codes are there for a reason....they will help you diagnose the car.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: 02 sensor bank 1 sensor 1-Is this drivers side or Passenger
    By cballweg in forum General Help
    Replies: 4
    Last Post: 01-15-2012, 11:44 AM
  2. Question: Reading trans temp stock sensor vs aftermarket sensor in pan
    By senicalj4579 in forum Computer & Tuning
    Replies: 1
    Last Post: 03-29-2011, 08:41 AM
  3. Knock Sensor/Oil Pressure Sensor Issue
    By Slow '99 in forum External Engine
    Replies: 1
    Last Post: 04-04-2007, 09:28 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •