Results 1 to 5 of 5

'01 Z28 Knock Sensor Code

This is a discussion on '01 Z28 Knock Sensor Code within the General Help forums, part of the LSx Technical Help Section category; I put a K&N filter in my SLP air box yesterday. Within two blocks the SES light came on. Took ...

  1. #1
    Junior Member David Ray's Avatar
    Join Date
    May 2009
    Location
    Lake City, Fl.
    Age
    51
    Posts
    77

    Onyx Black
    2001 Camaro Z28

    '01 Z28 Knock Sensor Code

    I put a K&N filter in my SLP air box yesterday. Within two blocks the SES light came on. Took it to the parts store had the code read as a knock sensor error. Cleared the code and it came back on a few miles down the road. Today, i removed the positive cable from the battery for 30 minutes then replaced the filter with the old fram filter. The SES light hasn't come back on. What's up with this? Is the K & N not good or does the knock sensors need to be desensitized?

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Another reason i think K&N is garbage, but anywho, do you have the actual code? I dont see how it would affect the knock sensor.
    Post up the code and we will go from there. Stick with the Cheap paper filter, they work just fine...
    J
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    Junior Member David Ray's Avatar
    Join Date
    May 2009
    Location
    Lake City, Fl.
    Age
    51
    Posts
    77

    Onyx Black
    2001 Camaro Z28

    Knock Sensor code

    I believe it was Po327. Which I think is the front bank. The guy at advanced auto parts wasn't much help other than reading the scanner and clearing it. I cleared it the second time by removing the postive battery cable. I don't know if the air volume increased so much that the pcm didn't compensate for it or what, but I've read that the knock sensors are one of the most sensitive to performance enhanced add-ons. I've driven about twenty miles with the old filter and the SES still hasn't come back on , so somethings up with the K & N at least for how my Z's calibrated.

  4. #4
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Sounds like the MAF might have been causing an issue. I think everyone here has heard or been through a K&N horror story. Pick up a can of CRC maf cleaner and clean the piss outta the wires on the maf and stick with a stock paper filter. Im sure you will see some results.

  5. #5
    TunedbyFrost.com Tuner Frost's Avatar
    Join Date
    Jul 2007
    Location
    Richmond VA
    Posts
    2,415

    LS1.com Sponsor
    GM Tuner

    The knock sensor code is unrelated to your mods.

    Also know that when it is active, the car is paranoid about you going WOT and it will pull max allowable timing at WOT until you get it fixed. It's only 4 degs, but it's 4 deg whenever you are 'into it'...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Knock sensor code and spark plugs....
    By Spikito in forum External Engine
    Replies: 10
    Last Post: 03-30-2013, 03:09 PM
  2. knock sensor code with new knock sensors?
    By zaaronz in forum General Help
    Replies: 13
    Last Post: 02-27-2011, 07:26 AM
  3. Knock Sensor Code...
    By Spikito in forum General Help
    Replies: 9
    Last Post: 09-20-2010, 11:27 PM
  4. knock sensor code ?
    By WS6S in forum Firebird / WS6
    Replies: 15
    Last Post: 05-22-2010, 08:41 PM
  5. Knock Sensor Low input code
    By clayton006 in forum General Help
    Replies: 3
    Last Post: 07-05-2007, 11:37 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •