Page 2 of 5 FirstFirst 12345 LastLast
Results 21 to 40 of 85

why am i slow

This is a discussion on why am i slow within the Drag Racing forums, part of the Racing Forums category; it seams to run good, i dont know?...

  1. #21
    Junior Member mxlplx71's Avatar
    Join Date
    Apr 2010
    Location
    iowa
    Posts
    84

    pewter
    1999 trans am

    it seams to run good, i dont know?

  2. #22
    BANGIN GEARS>STAB N STEER BLK2KSS's Avatar
    Join Date
    Nov 2009
    Location
    Jacksonville FL
    Age
    34
    Posts
    855

    TRIPLE BLACK
    2000 CAMARO SS M6 #2100

    hows your cluth? it sounds to me like it may be slipping...

  3. #23
    Junior Member mxlplx71's Avatar
    Join Date
    Apr 2010
    Location
    iowa
    Posts
    84

    pewter
    1999 trans am

    could be the clutch,, it seems like when i drove it a few years ago when my stepdad owned it it pulled alot harder all through the gears.

  4. #24
    BANGIN GEARS>STAB N STEER BLK2KSS's Avatar
    Join Date
    Nov 2009
    Location
    Jacksonville FL
    Age
    34
    Posts
    855

    TRIPLE BLACK
    2000 CAMARO SS M6 #2100

    a good way to test would be to take it for a drive, put it in 4th or 5th and floor it. if the rpms jump and your not really going much faster then its your clutch. I had my clutch go bad in my old formula back in the day before i knew much about cars and had no idea why is was so slow all of a sudden. I remember getting murdered by a turbo vw beetle and was like wtf! lol. The tire wernt chiping anymore and it just felt like it didnt want to go anywhere. Then I figured it out, fixed it and got a rematch with the beetle

  5. #25
    Junior Member mxlplx71's Avatar
    Join Date
    Apr 2010
    Location
    iowa
    Posts
    84

    pewter
    1999 trans am

    ive had clutches go bad in other cars before, it doesnt seem like it slips at all on the street,... but it breaks the tires loose pretty easy even shifting into second.

  6. #26
    Junior Member
    Join Date
    Apr 2010
    Location
    florida
    Posts
    33

    black
    01 camaro SS

    something is def. not right.. your at least 10mph off from where u should be.. could be a clutch or your just down on a lot of power for some reason. does the car still have the stock cats? if so they could be clogged, whens the last time u checked plugs,wires, fuel filter? those are the first things i would look into.

  7. #27
    NY Representative basballny2's Avatar
    Join Date
    Aug 2007
    Location
    NeW YoRk
    Posts
    3,393

    Red
    2001 ws6

    start with the basics......do a full check up on the car. change your plugs/wires/fuel filter/check your air filter etc. even with a 2.4 you shouldnt be in the 15's.....however, this might all just be a driver mod no offense

  8. #28
    Junior Member mxlplx71's Avatar
    Join Date
    Apr 2010
    Location
    iowa
    Posts
    84

    pewter
    1999 trans am

    it could be me but its not the first time i raced a stick, my turbo omni ran 13s
    the car has 59000 miles so ill do a tune up.
    can i get rid of the cats without codes, no smog in iowa.

  9. #29
    Junior Member mxlplx71's Avatar
    Join Date
    Apr 2010
    Location
    iowa
    Posts
    84

    pewter
    1999 trans am

    i also powershifted every gear w no misses.

  10. #30
    Junior Member
    Join Date
    Apr 2010
    Location
    florida
    Posts
    33

    black
    01 camaro SS

    by removing the cats you lose the rear O2 sensors which will throw a code unless u get it turned off in a tune.

  11. #31
    Junior Member mxlplx71's Avatar
    Join Date
    Apr 2010
    Location
    iowa
    Posts
    84

    pewter
    1999 trans am

    a few years ago my dad let me tack it to the track and i got a 13.65 out of it,, the plugs k&n filter and maf look great, the only change is a newer flowmaster muffler.

    maybe the fuel filter?
    also what hp could i get out of removing the cats and a tune?

  12. #32
    Junior Member mxlplx71's Avatar
    Join Date
    Apr 2010
    Location
    iowa
    Posts
    84

    pewter
    1999 trans am

    i just found out by reading the threads i have the worst flowing muffler
    flowmaster, im going t go magnaflow soon. then tires.

  13. #33
    Member 4thGenTA's Avatar
    Join Date
    Mar 2009
    Location
    farmington
    Posts
    181

    black
    2002 firebird trans am

    I don't think having a flowmaster cat back will make that much of a difference, they flow a little better then stock, but not by much.

  14. #34
    NY Representative basballny2's Avatar
    Join Date
    Aug 2007
    Location
    NeW YoRk
    Posts
    3,393

    Red
    2001 ws6

    slowmasters......however, they wont add 2 seconds to your car. change the fuel filter, its cheap

  15. #35
    Member El Toro Loco's Avatar
    Join Date
    Jun 2008
    Location
    Harlingen, tx
    Posts
    757

    pewter
    2001 Trans AM WS6

    wow hes only trappin in the 90's

  16. #36
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    If you have a K&N filter, clean your MAF. Even if it "looks" clean, clean it anyway. They sell CRC MAF cleaner at your local autoparts store.

  17. #37
    Junior Member mxlplx71's Avatar
    Join Date
    Apr 2010
    Location
    iowa
    Posts
    84

    pewter
    1999 trans am

    the car sat in a garage for almost two years, filters going after work today.

  18. #38
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Did you put new gas in it?

  19. #39
    Member RedSmokey's Avatar
    Join Date
    Feb 2009
    Location
    CA (sacramento)
    Posts
    226

    Black
    F250

    Quote Originally Posted by mxlplx71 View Post
    the car sat in a garage for almost two years, filters going after work today.
    Quote Originally Posted by 35th-ANV-SS View Post
    Did you put new gas in it?
    What he said^^^ And did you change the oil? A lot of crap can build up in different area's of the car in two years...

  20. #40
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by mxlplx71 View Post
    i just found out by reading the threads i have the worst flowing muffler
    flowmaster, im going t go magnaflow soon. then tires.
    Don't believe everything you read. We tried a dozen different catbacks on the same car over a period of time, including 2 different flowmaster setups, and it ran nearly identical, the car didn't care which 3 inch catback was on it. Changing to a 4 inch catback and things got interesting. Even the flowmaster muffler on that system didn't change a thing over the spintech muffler.
    I wouldn't worry about it right now, that is not your problem.

Page 2 of 5 FirstFirst 12345 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. slow 5.0
    By Badass WS6 in forum Kill Stories
    Replies: 45
    Last Post: 04-05-2010, 12:18 PM
  2. Got Slow!
    By InEEdSPEED in forum Camaro / SS
    Replies: 12
    Last Post: 03-11-2010, 05:29 AM
  3. why is my ws6 so slow???
    By 98ws6-girl in forum Firebird / WS6
    Replies: 46
    Last Post: 08-16-2007, 07:22 AM
  4. Wow Slow day here...
    By RoysTransAM in forum Rocky Mountain Members
    Replies: 28
    Last Post: 12-24-2006, 10:42 PM
  5. why is ls1.com so slow?
    By sgt0704 in forum Request and Feedback
    Replies: 90
    Last Post: 06-04-2006, 11:44 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •