Results 1 to 3 of 3

Please God Somebody Help!

This is a discussion on Please God Somebody Help! within the Drag Racing forums, part of the Racing Forums category; First off let me start by saying that I am in no way a newbie to f-body's or drag racing. ...

  1. #1
    Junior Member
    Join Date
    Apr 2006
    Location
    Rocky Face, GA
    Posts
    39

    Red
    99 camaro Z-28

    Thumbs down Please God Somebody Help!

    First off let me start by saying that I am in no way a newbie to f-body's or drag racing. I might not be a pro or a mechanic but I do know a little. With that being said I just ran my current car down the 1/8th mile for the first time tonight, which is my 6th f-body I have owned. I am almost ashamed to even put my numbers on here because I think someone swapped out my ls-1 for a v-6 when I wasn't looking. Here are my numbers.

    reaction...... .885 (could be better)
    60 ft...... 2.166 (not to bad for street tires)

    Lets stop there and go back to my previous car that I owned which is a bone stock 99 z-28 six speed and compare

    reaction..... .968
    60 ft...... .2.192
    330ft...... 5.821
    1/8th...... 8.764
    mph...... 83.19

    That was bone stock! Now back to my current car.

    330ft...... 6.154
    1/8th...... 9.4117
    mph...... 75.23

    What the hell is wrong with this car. I know its a a4 with 3.23 gears and I know that temps where in the 80s with high humidity but come on. I looked back at my 6speed car and I spun like hell on one run with a 2.4 60ft and still ran better than that. Where in the hell is my power? One thing to note is that my service engine soon light came on the second run. The car felt fine not missing or overheating. Its getting off the line great but 3rd gear just doesn't feel like it is pulling very hard. Some guys at the track told me that if the check engine light is on that the car is in a safety mode as far as timing goes and wont run great. Any help on this matter would be greatly appreciated. I dont know what to do.

  2. #2
    Junior Member
    Join Date
    Apr 2006
    Location
    Rocky Face, GA
    Posts
    39

    Red
    99 camaro Z-28

    Track weather was 80 degrees with a humidy of 78 percent

  3. #3
    Senior Member
    Join Date
    Sep 2005
    Location
    rochester,ny
    Age
    39
    Posts
    2,667

    pewter
    2001 z28 lingenfelter 383

    like the guy at the track said your car was in limp mode when your service engine light came on......wasnt runnning right.....fix it and try again

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •