Results 1 to 5 of 5

Motor's done..threw a rod

This is a discussion on Motor's done..threw a rod within the Drag Racing forums, part of the Racing Forums category; Well, looks like my 408 is done. Was down at the rack dialing my suspension in and one of the ...

  1. #1
    Senior Member cam02ss's Avatar
    Join Date
    Aug 2005
    Location
    Purcellville, VA
    Posts
    2,139

    Motor's done..threw a rod

    Well, looks like my 408 is done. Was down at the rack dialing my suspension in and one of the rods let loose. Went through the side of the block and through the oil pan. Sucks, but this is a part of racing. I'll know this week if the head is ok, I'm sure the crank will be worthless. The heads are TEA/TF 235s, if they are ok I'll figure out another bottom end from there. I know someone who has a 440 LSX, so I was thinking about having the heads reworked to 245's and continuing on.

    Carnage:



  2. #2
    Waiting on the Tree transamtom's Avatar
    Join Date
    Jul 2005
    Location
    Niagara Falls Ont.Canada
    Posts
    927

    NBM
    1999 TA A4

    Ouch,that looks expensive.

    Have you figured out how it happened?

    Did it get leaned out on the juice?

    I lost one like that.

  3. #3
    Senior Member cam02ss's Avatar
    Join Date
    Aug 2005
    Location
    Purcellville, VA
    Posts
    2,139
    We think the bearing went first, vibration caused the rod to go and the result is what you see here. That or a rod bolt broke. Nope, it was an NA run, we were dialing in the suspension and had planned to make nitrous passes later that morning.

  4. #4
    Waiting on the Tree transamtom's Avatar
    Join Date
    Jul 2005
    Location
    Niagara Falls Ont.Canada
    Posts
    927

    NBM
    1999 TA A4

    That sucks big time,did the damper fail?

  5. #5
    Senior Member cam02ss's Avatar
    Join Date
    Aug 2005
    Location
    Purcellville, VA
    Posts
    2,139
    I dunno, oil starvation seems to be the verdict. We had switched the setup over to solid roller and were revving out to 8k. I'm getting a hell of a hook up on a 440 LSX so I'll use a dry sump this time.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: I threw a code....
    By transamgirl89 in forum General Help
    Replies: 16
    Last Post: 07-29-2011, 10:54 PM
  2. Threw a code???
    By hm3tocapt in forum Computer & Tuning
    Replies: 10
    Last Post: 09-30-2009, 09:30 AM
  3. Threw a Code?? (help)
    By Raoul-Duke in forum Computer & Tuning
    Replies: 6
    Last Post: 08-19-2008, 11:46 PM
  4. NEED HELP: Think I threw a rod
    By TransAmcoupe98 in forum Firebird / WS6
    Replies: 2
    Last Post: 07-25-2007, 08:14 PM
  5. Threw a code
    By uLs1a in forum Drivetrain
    Replies: 1
    Last Post: 09-17-2006, 04:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •