Results 1 to 8 of 8

Question about running a 275 on the front.

This is a discussion on Question about running a 275 on the front. within the Wheels and Tires forums, part of the General Help category; I have a 97 LT1 Camaro. Im thinking of buying some 17x9's. Questionis; would there be a fittment issue with ...

  1. #1
    Junior Member danjo11's Avatar
    Join Date
    May 2011
    Location
    Kentucky
    Posts
    62

    Victory Red
    2000 SS

    Question about running a 275 on the front.

    I have a 97 LT1 Camaro. Im thinking of buying some 17x9's. Questionis; would there be a fittment issue with running 275's on the front??? I don't want them to rub when turning. Thanks for the help!

  2. #2
    Senior Member 2001camaroSS's Avatar
    Join Date
    Feb 2010
    Location
    Greenwood, IN
    Posts
    3,508

    Light Pewter Metallic
    2001 Camaro SS

    Those will work just fine without rubbing, assuming the wheel does not have some weird offset. A 17x9 wrapped with a 275 is stock for the SS/WS6s, which equates to fitment to the 4th gen cars.

  3. #3
    Member dav-02ws6-m6's Avatar
    Join Date
    Mar 2010
    Location
    VA
    Posts
    294
    2002 trans am ws6

    agree. i have 275's up front and i don't have any issues.

  4. #4
    Member fastt's Avatar
    Join Date
    Aug 2010
    Location
    Michigan
    Posts
    324

    white
    2002 z28 camaro

    I have 275 up front on my car no rubbing at all.

  5. #5
    Junior Member danjo11's Avatar
    Join Date
    May 2011
    Location
    Kentucky
    Posts
    62

    Victory Red
    2000 SS

    Thanks guys for all the good feedback!!
    -- We are the people your parents warned you about.

  6. #6
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    315's work as well

  7. #7
    Senior Member 2001camaroSS's Avatar
    Join Date
    Feb 2010
    Location
    Greenwood, IN
    Posts
    3,508

    Light Pewter Metallic
    2001 Camaro SS

    Quote Originally Posted by c5z28 View Post
    315's work as well
    that requires mods tho doesnt it.

  8. #8
    Member MudStainKILLA's Avatar
    Join Date
    Dec 2009
    Location
    Stateside
    Posts
    468

    Black
    2002 firebird T/A WS6-A4

    same here, 275s on stock 17x9 speedlines and no issues

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 08-18-2010, 10:32 AM
  2. Who is running front components and a sub only?
    By Red97LT1 in forum Stereo and Electronics
    Replies: 12
    Last Post: 03-03-2010, 04:21 PM
  3. Wanted: Front T/A DRL Running Lights
    By nhra-trans-am in forum Parts Wanted / Trade
    Replies: 7
    Last Post: 02-21-2009, 01:09 AM
  4. front running lights
    By Z ROADSTER in forum Stereo and Electronics
    Replies: 8
    Last Post: 06-08-2007, 06:06 PM
  5. I Need Front Running Lights!!!
    By lrader99 in forum Parts Wanted / Trade
    Replies: 2
    Last Post: 01-07-2006, 10:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •