Results 1 to 13 of 13

Cleaning the Engine Bay

This is a discussion on Cleaning the Engine Bay within the Appearance Section forums, part of the General Help category; Hey guys, what do you use to clean your engine bay? I.E Chemicals, tools etc. Also any methods you recommend ...

  1. #1
    Junior Member
    Join Date
    Aug 2009
    Location
    Bay Area Cali
    Posts
    86

    White
    1995 Camaro Z28

    Cleaning the Engine Bay

    Hey guys, what do you use to clean your engine bay? I.E Chemicals, tools etc. Also any methods you recommend

    Thanks

  2. #2
    War Machine BIG GUNS's Avatar
    Join Date
    May 2007
    Location
    St. Louis MO.
    Age
    53
    Posts
    2,100

    Black
    00 Trans Am/Auto

    Simple Green and plenty of water. That is about all you need.

  3. #3
    Junior Member
    Join Date
    Aug 2009
    Location
    Bay Area Cali
    Posts
    86

    White
    1995 Camaro Z28

    really?? would that work? Ive been useing heavy cleaning agents, and they cant even get the job done!!

  4. #4
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    I use wet rags to afraid to use a hose for fear of fucking up the electrics, carb cleaner gets rid of some grime though I wouldn't reccomend that on paint.

  5. #5
    She Moderator KahanaReef's Avatar
    Join Date
    Jul 2008
    Location
    So Cal
    Age
    54
    Posts
    15,590

    Arctic White
    2000 Camaro Z28

    I use old tooth brushes to loosen any stubborn dirt.

  6. #6
    Member planemech2's Avatar
    Join Date
    Aug 2005
    Location
    Greybull, Wy.
    Age
    71
    Posts
    119

    Black/Black/Black
    2000 Camaro SS Vert #5301

    Don't spray or pour water if you have an LT1, it will fry the Optispark.
    2000 SS vert, #5301, triple black, A4, leather, 3.23,SLP lid & D/D, STB, chrome 5 spokes
    USN '64-'88
    #3 1951-2001

    www.fquick.com/planemech2


  7. #7
    War Machine BIG GUNS's Avatar
    Join Date
    May 2007
    Location
    St. Louis MO.
    Age
    53
    Posts
    2,100

    Black
    00 Trans Am/Auto

    Oh god, sorry. Yeah, that is true. Sorry I told you to use a hose or anything there.

    LS1s are okay with it but, the LT is sensitive to water around the optispark.

  8. #8
    Junior Member
    Join Date
    Aug 2009
    Location
    Bay Area Cali
    Posts
    86

    White
    1995 Camaro Z28

    What dose the optispark do?
    Where is it?
    How do I check if its broken?

    I sprayed some water

  9. #9
    Junior Member
    Join Date
    Aug 2009
    Location
    Bay Area Cali
    Posts
    86

    White
    1995 Camaro Z28

    Bump! HELP!

  10. #10
    NY Representative basballny2's Avatar
    Join Date
    Aug 2007
    Location
    NeW YoRk
    Posts
    3,393

    Red
    2001 ws6


  11. #11
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Let it dry and start the car up if it runs fine then you didn't screw it up-didn't we already tell you not to use the hose?

  12. #12
    Junior Member
    Join Date
    Aug 2009
    Location
    Bay Area Cali
    Posts
    86

    White
    1995 Camaro Z28

    Quote Originally Posted by c5z28 View Post
    Let it dry and start the car up if it runs fine then you didn't screw it up-didn't we already tell you not to use the hose?
    Ok, the car is fine but I did it before you all told me not to! Either way, everything is just fine.

  13. #13
    War Machine BIG GUNS's Avatar
    Join Date
    May 2007
    Location
    St. Louis MO.
    Age
    53
    Posts
    2,100

    Black
    00 Trans Am/Auto

    I think it was my fault. I told you that without looking to see what type motor you had.

    Sorry bro. Hope all is well.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question Regarding Cleaning Engine/Engine Bay
    By Badass WS6 in forum Showcar and Detailing
    Replies: 7
    Last Post: 08-07-2010, 05:44 PM
  2. Question Regarding Cleaning Engine/Engine Bay
    By Badass WS6 in forum Appearance Section
    Replies: 4
    Last Post: 07-20-2010, 07:22 PM
  3. LT1 Engine Cleaning
    By MeatL0af in forum Showcar and Detailing
    Replies: 5
    Last Post: 06-18-2007, 02:39 PM
  4. Replies: 0
    Last Post: 06-01-2007, 11:00 AM
  5. Replies: 0
    Last Post: 04-24-2007, 02:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •