Results 1 to 5 of 5

why do i keep blowing fuses?

This is a discussion on why do i keep blowing fuses? within the Stereo and Electronics forums, part of the General Help category; i'm trying to hook up a mtx amp to the 8's i installed a while back. the problem is this. ...

  1. #1
    Compulsive F bomb dropper sgt0704's Avatar
    Join Date
    Apr 2006
    Location
    yuma arizona
    Age
    36
    Posts
    1,985

    silver
    1998 Z28

    why do i keep blowing fuses?

    i'm trying to hook up a mtx amp to the 8's i installed a while back. the problem is this. last night the amp would come on. i tried hooking them to the subs, then they wouldn't play. then the amp just started blowing fuses. i have the wires run down the passenger side.

    the battery wire goes across the motor to the battery auxillary post. is that not a good place for it? it seemed the most logical to me. then i had found one of my rca wires had got punctured by a screw that holds the side trim down, fixed the problem, even unhooked the rca's from the amp. and with the ground, remote, and batt wire, it's still blowing fuses.. WTF?

    the ground wire is attached to the top of the wheel well. i've used a test light, and it's getting power, and i'm not finding any other holes or anything in any of the other wires.

    so why do i keep blowing fuses? is it because the wires are run along the passenger side? should they be run down the middle? i just don't get why the amp was powering up last night, but now it's just popping fuses.

    thanks.

  2. #2
    1 BAD ASS BOWTIE StangKiller615's Avatar
    Join Date
    Feb 2006
    Location
    Nashville Tn
    Age
    35
    Posts
    1,347

    Black on Black
    2001 Camaro SS

    Sounds like you have a short somewhere. The fuses are blowing because of way to much current. What size fuse are you using? If it is too small, it will pop. you also want to retrace all wires and make sure there is nothing interfering with them.

  3. #3
    Junior Member
    Join Date
    Mar 2006
    Location
    St. Louis
    Age
    38
    Posts
    43

    black
    02 z28

    doesn't really matter what side of the car you run the wires down. check for a short, loose wire, bad ground, or you may just need a bigger fuse (in line fuse).

  4. #4
    Compulsive F bomb dropper sgt0704's Avatar
    Join Date
    Apr 2006
    Location
    yuma arizona
    Age
    36
    Posts
    1,985

    silver
    1998 Z28

    everything was hooked up good. nothing loose. etc... when i put a 40 fuse on the power wire instead of the 30 the fuse on the amp blew. i just don't get it.

  5. #5
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    That would be a dead short, somwhere in the sytem there is a wire that going straight to ground, trace all wire from the battery to the amp, then the speakers. Your amp may have also shorted on the inside as well.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Blowing Air Conditioning Fuses
    By ls1camino in forum General Help
    Replies: 6
    Last Post: 07-29-2011, 06:15 PM
  2. blowing fuses car wont start need help
    By white02Z28 in forum General Help
    Replies: 4
    Last Post: 01-16-2008, 11:35 AM
  3. Blowing Fuses!
    By Ryans99LS1 in forum General Help
    Replies: 3
    Last Post: 12-07-2007, 09:16 PM
  4. Blowing fuses
    By 2000 SS Beast in forum General Help
    Replies: 7
    Last Post: 10-10-2007, 10:34 PM
  5. fuses keep blowing???
    By blackTA6585 in forum General Help
    Replies: 4
    Last Post: 04-06-2006, 09:27 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •