Results 1 to 4 of 4

Weird problem with display

This is a discussion on Weird problem with display within the Stereo and Electronics forums, part of the General Help category; Not sure if others have encountered this, but in my girlfriends 02' Firebird Convertible lately the display on the stock ...

  1. #1
    Member Firebird Phoenix's Avatar
    Join Date
    Feb 2007
    Location
    STL Area, Illinois Side
    Posts
    519

    Black
    1995 Firebird

    Weird problem with display

    Not sure if others have encountered this, but in my girlfriends 02' Firebird Convertible lately the display on the stock "Pontiac Monsoon" is messing up. The numbers (for a radio station for example or the time) are missing parts or messed up. It's really odd, the only thing that remains consistent is that it happens for the first few minutes after starting the car up, and usually "fixes" if I change the station or turn the radio off but sometimes that doesn't even work for a while. Any clues??? I wouldn't think a low mileage car (she bought it from the original owner at 25k miles) would do this. Thanks for any responses.

  2. #2
    Member
    Join Date
    Aug 2005
    Location
    Pittsburgh
    Age
    44
    Posts
    413
    My 95 Ta does that too.

  3. #3
    Senior Member GULLETT17's Avatar
    Join Date
    Oct 2007
    Location
    Muncie, IN
    Posts
    2,554

    00 TA PWTR, 98 VertTA NBM
    80 TA BLK, 80 Formula NBM

    its monsoon man . . . both my 98 and 00 do it.
    2000 TA, A4, LS6 intake, Magnaflow, WS9 hood, BMR STB, UMI boxed SFC, Spohn LCA, 9" Ford
    1998 TA Vert,​ NBM, M6, Flowmaster, WS6 hood, WS6 airbox, C6 wheels, UMI SFC, BMR STB
    1998 Bird, Black, V6, A4, 18" 077's, Wings West Body Kit
    1980 Formula, NBM, 402BB, cam, DR timing, LT headers, 3" TD w/ flowmasters, TH350
    1980 TA, Black, 301, bone stock

  4. #4
    I have a 02 WS6 it happens it is no big deal like you said once you change the station everything is good again

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Weird Problem?
    By ADICECCA21 in forum Firebird / WS6
    Replies: 11
    Last Post: 05-07-2012, 05:36 AM
  2. weird problem!
    By barryz in forum General Help
    Replies: 3
    Last Post: 05-24-2009, 12:14 PM
  3. Weird Radio display...
    By chad3113 in forum Stereo and Electronics
    Replies: 3
    Last Post: 07-04-2007, 09:28 AM
  4. Need a little help here weird problem
    By 98Roadster6speed in forum Corvette
    Replies: 3
    Last Post: 09-29-2005, 04:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •