Results 1 to 12 of 12

turn signals don't work

This is a discussion on turn signals don't work within the Stereo and Electronics forums, part of the General Help category; For some reason my turn signals aren't working. The arrows don't light up on the dash and the tail lights ...

  1. #1
    Rice Hungry GottaHaveLS1's Avatar
    Join Date
    Oct 2005
    Location
    Connecticut
    Age
    30
    Posts
    1,316

    Black
    1999 Trans Am M6

    turn signals don't work

    For some reason my turn signals aren't working. The arrows don't light up on the dash and the tail lights don't do anyting. all the lights are fine. I checked every damn fuse on the car and they look good and are the right "ampage".

    is there anything else i can do?

  2. #2
    Crazy Canuck ! Eugenio_SS's Avatar
    Join Date
    Jun 2002
    Location
    Montreal, CANADA
    Age
    42
    Posts
    3,190

    triple-black
    2000 CamaroSS convertible

    if one of the bulbs are burnt, the turn signal won't work.
    Eugenio_SS
    almost stock triple-black 2000 SS convertible with 17x11s on all 4 w/ 315s at the track or on the street with 18x10.5s on all 4 w/ 315s: (1), (2)

  3. #3
    Rice Hungry GottaHaveLS1's Avatar
    Join Date
    Oct 2005
    Location
    Connecticut
    Age
    30
    Posts
    1,316

    Black
    1999 Trans Am M6

    hmmm, i'm pretty sure they're working alright.. i had the tail light off the car and all 3 bulbs worked, including the really small one in the corner. at first one of them wasn't working and i swapped it with another and they all turned on. i'll have to take another look at it.

  4. #4
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    check you fuses...

    and before any one else says it... "check your turn signal fluid level"...

  5. #5
    rapter34
    Guest
    Quote Originally Posted by Spaz View Post
    check you fuses...

    and before any one else says it... "check your turn signal fluid level"...

    Spaz is right one of the most over looked fluids on any car. So make sure to check it and if it is running low you can always add this stuff the best on the market.


  6. #6
    Rice Hungry GottaHaveLS1's Avatar
    Join Date
    Oct 2005
    Location
    Connecticut
    Age
    30
    Posts
    1,316

    Black
    1999 Trans Am M6

    if u read my first post, i said i checked every fuse on the car... is there any electronic device that controls the blinker??

  7. #7
    $ 25,000 panty dropper VENOMOUS's Avatar
    Join Date
    Jan 2008
    Location
    Waco
    Posts
    1,186

    2005 Ram SRT-10 QC 8.3l
    1999 FRC Black

    hEY MAN, Don't fret. It is your DRL bulbs, or daytime running lamps. They are the ones that are amber in front of your car. With the key on, engine off, emergency brake off, they should be lit. If they are on then it's the turn signal filament of the same bulb. These things have a poor connecter seal and while driving in rain or washing water enters this connector and rusts the contacts. It is for sure your problem. You can reach through the hole under the light and feel the socket and turn to unplug from light housing. ( this is for T/A only, not sure about Firebird/Formula but sure it's similar.

  8. #8
    Crazy Canuck ! Eugenio_SS's Avatar
    Join Date
    Jun 2002
    Location
    Montreal, CANADA
    Age
    42
    Posts
    3,190

    triple-black
    2000 CamaroSS convertible

    i'm with venomous... check the front ones.
    as he describes, it happened to me... te DRl ewre on but my blinkers weren't working... when replaced the bulb, all was ok... on your dash, the turn arrow will stay lit and not blink... that means a bulb is burnt... just need to figure which one.

  9. #9
    Rice Hungry GottaHaveLS1's Avatar
    Join Date
    Oct 2005
    Location
    Connecticut
    Age
    30
    Posts
    1,316

    Black
    1999 Trans Am M6

    My problem is that the blinker arrows on the dash don't come on at all. i replaced all the lights in the back except the reverse and dinky corner light. i guess i'll just have to replace the front ones and see what happens. is there any kind of device that controls the blinkers? my dad says he has one on his ford taurus and he can access it from within the glove box. the weird thing is that my blinkers were blinking really slow for a long time (never bothered to try to fix it) and then they suddenly stopped working. my hazards work tho...

  10. #10
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    It probably needs a new flasher. It is near the steering column I think.

  11. #11
    <b>"iznuthn"2 a BOSS!</B> IZNUTHN's Avatar
    Join Date
    Aug 2005
    Location
    SF,CA
    Age
    40
    Posts
    84
    Blog Entries
    1

    ONYX BLACK
    02 Z28

    I have the same problem with my 2002 Z28. In the morning my signals were working but when I washed my car and was all done with it I noticed that when I turned my signal left it didnt signal on the dash like it used to.

  12. #12
    Junior Member
    Join Date
    Apr 2014
    Location
    santa rosa
    Posts
    7
    Hey guy maybe u can help me when my lights r off the blinkers work great I trun on the praking lights or head lights my passenger side light won't blink just stays on

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. help ....my turn signals dont work
    By Speedy_Gonzales in forum General Help
    Replies: 19
    Last Post: 03-21-2010, 09:15 AM
  2. turn signals don't work
    By GottaHaveLS1 in forum General Help
    Replies: 1
    Last Post: 05-29-2008, 04:21 PM
  3. Turn signals and brake lights don't quite work..HELP!!
    By Kaution vBi in forum General Help
    Replies: 1
    Last Post: 08-05-2007, 10:45 AM
  4. Turn signals wont work but hazards do??
    By Toneloc71sr in forum General Help
    Replies: 5
    Last Post: 05-31-2007, 01:48 AM
  5. Help with my Turn Signals
    By mustngdave in forum General Help
    Replies: 3
    Last Post: 05-05-2007, 11:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •