Results 1 to 5 of 5

Subs suddenly quit workin

This is a discussion on Subs suddenly quit workin within the Stereo and Electronics forums, part of the General Help category; I have two 12 Inc diamond D3 subs and a Diamond D3 8OO watt 2 channel amp with alpine head ...

  1. #1
    Member izzhemp's Avatar
    Join Date
    May 2009
    Location
    Osawatomie KS
    Age
    28
    Posts
    324

    white/Black
    1999 Pontiac Firebird

    Subs suddenly quit workin

    I have two 12 Inc diamond D3 subs and a Diamond D3 8OO watt 2 channel amp with alpine head unit and alpine type S front door speakers (only door speakers in car) and a 3OOO watt 4 gauge amp wiring kit with power acoustic power cap, i just got TA door panels i was painting them only got pass side installed driver side panel not on including door speaker i do have window switches hooked up on DriveR side though so i only have the one door speaker goin on pass side i turned down Stero all the way rolled up window on driver side thought it made a noise so was listening to it got it rolled up then turned volume from O Bak up and had no subs just door speaker, my power cap is not comin on i checked the power wire and ground wire goin to cap no issues that i seen all fuses on amp an fuse at battery are fine the amp is gettin power do to cap not coming on i do have bad battery Aswell but did the cap go out i got it used everything else is less than year old? i haven't tried hookin power an ground directly to amp yet just happened tonight an its cold an i have work in mornin but i need second opinion on whether or not power cap went out thanks

  2. #2
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Typically, when a cap goes bad, it still allows power through, just doesn't retain a charge.

    I think your on the right track, just start eliminating variables, like removing the cap. Then try the speaker.


    With electrical components, anything can go bad, so dont overlook anything.

  3. #3
    Member izzhemp's Avatar
    Join Date
    May 2009
    Location
    Osawatomie KS
    Age
    28
    Posts
    324

    white/Black
    1999 Pontiac Firebird

    Figured it out rca wires messed up some how there less than year old to weird but cheaper than amp

  4. #4
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Glad it was a cheap fix.

  5. #5
    Member izzhemp's Avatar
    Join Date
    May 2009
    Location
    Osawatomie KS
    Age
    28
    Posts
    324

    white/Black
    1999 Pontiac Firebird

    Smile

    me to, now that i know it wasnt system i sold system and ordering 12" Alpine type X and a 2000 watt mono block class D Alpine MRP-M2000 Amp and a Ground shaker sealed 12" inch hatch box, im goin to pound

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Lt1 suddenly dies, help please
    By dirttrax in forum General Help
    Replies: 20
    Last Post: 03-06-2010, 12:00 PM
  2. dvd drive not workin
    By El Toro Loco in forum Computers / Gaming
    Replies: 6
    Last Post: 02-20-2010, 11:48 AM
  3. Workin in texas
    By Iyyob in forum New Member Introductions
    Replies: 6
    Last Post: 02-18-2009, 07:12 PM
  4. Car's Workin Great!!
    By R_Yates69@Hotmail.com in forum New Member Introductions
    Replies: 1
    Last Post: 07-12-2007, 07:02 AM
  5. cd player not workin
    By Bandit1 in forum Stereo and Electronics
    Replies: 2
    Last Post: 09-09-2006, 04:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •