Results 1 to 6 of 6

Stereo and power windows losing power randomly

This is a discussion on Stereo and power windows losing power randomly within the Stereo and Electronics forums, part of the General Help category; I have had my 2000 Camaro Z28 for about 6 months now and I have noticed that the head unit ...

  1. #1
    Junior Member
    Join Date
    Oct 2010
    Location
    Goose Creek, SC
    Age
    30
    Posts
    2

    Red
    2000 Camaro Z28

    Exclamation Stereo and power windows losing power randomly

    I have had my 2000 Camaro Z28 for about 6 months now and I have noticed that the head unit (I have a monsoon system) will randomly shut off. Music stops, the clock turns off and the windows won't roll up or down. Sometimes I can go weeks without it happening and other times it will turn off and back on many times in one day. After observing it for long enough I have noticed that breaking seems to cause it to shut off, and sometimes simply accelerating the car or hitting the dash above the head unit will cut it back on. I also recently noticed the sound getting louder on one side when I turn rapidly in the other direction, I have only really witnessed the sound shifting twice but thought it could be another symptom of the problem.

    I have no idea whats going on, but I thought this would be the place to put it in case its a common problem. Anyone dealt with anything like this? I'm about to install a better stereo system but not until this is sorted out.
    Last edited by Woodles; 10-09-2010 at 04:42 PM.

  2. #2
    Member 20ws6speed01's Avatar
    Join Date
    Jun 2009
    Location
    Winston,OR
    Posts
    272

    blue
    2001 WS6

    may want 2 remove the radio and have look at the wires....

  3. #3
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Sounds like an issue with the Body Control Module (BCM). I think Smittro did a write up recently on how to repair it -- simply need to re-solder a few connections that tend to go bad on the board. I'll see if I can find it...

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban


  5. #5
    Member supaxero's Avatar
    Join Date
    Sep 2008
    Location
    desert
    Posts
    179

    metallic pewter
    2000 Trans Am WS6

    check the body control module under your glove box. I had the same issue with the radio and windows. Its a common issue in our cars. The soldering had cracks in it.

  6. #6
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    +3 on BCM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: Stereo + Windows Stop Working Randomly Ctd..
    By scStormChaser in forum Stereo and Electronics
    Replies: 4
    Last Post: 09-16-2014, 08:34 AM
  2. Help: Losing power at wot at the drag strip
    By speedfreak1 in forum General Help
    Replies: 23
    Last Post: 10-05-2012, 11:46 PM
  3. Power windows and stereo
    By BWA2110 in forum Stereo and Electronics
    Replies: 5
    Last Post: 08-23-2010, 10:25 AM
  4. 00 Vette losing power?
    By Jerry's 99SS in forum Corvette
    Replies: 1
    Last Post: 05-04-2010, 12:53 AM
  5. Windows and Stereo Power cuts out
    By 59convertible in forum Stereo and Electronics
    Replies: 1
    Last Post: 06-24-2007, 08:48 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •