Results 1 to 8 of 8

Speakers not working

This is a discussion on Speakers not working within the Stereo and Electronics forums, part of the General Help category; My speakers in the middle suddenly stopped working. There is no bass at all and it's driving me crazy. Any ...

  1. #1
    Member ezwip's Avatar
    Join Date
    May 2008
    Location
    purgatory
    Posts
    354

    Black
    02 Z28 M6

    Speakers not working

    My speakers in the middle suddenly stopped working. There is no bass at all and it's driving me crazy. Any ideas why this might have happened? Could it be the amp or fuse?

  2. #2
    Member ezwip's Avatar
    Join Date
    May 2008
    Location
    purgatory
    Posts
    354

    Black
    02 Z28 M6

    It's the 02 camaro z28 with the Monsoon stereo system. The mid on the right is out and the speaker in front is out. Both are brand new. Sounds like the amp is going out?

  3. #3
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Have you checked to see if a wire came loose since they are new?

  4. #4
    Member ezwip's Avatar
    Join Date
    May 2008
    Location
    purgatory
    Posts
    354

    Black
    02 Z28 M6

    Ok I've got the head unit in there now. The Monsoon stereo was the problem. The little tray and filler that I had isn't going to fit so I'll have to swing by a stereo shop to buy a new one. I'm looking pretty ghetto until then. Has anyone any advice on hooking the antenna back up in this thing? I can't believe how difficult that is. The new unit is a Kenwood. It was difficult to pull out and it seems impossible to push back in. Is there a trick to this? Any advice? Also, how do you get the door panels off.
    Last edited by ezwip; 07-28-2008 at 09:09 PM.

  5. #5
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    You need an adaptor for the antenna. The factory one is smaller than the headunit one.

  6. #6
    Member ezwip's Avatar
    Join Date
    May 2008
    Location
    purgatory
    Posts
    354

    Black
    02 Z28 M6

    I managed to install it last night kinda. The last kit was from a truck. So I got a dash kit on the way home from work. It didn't fix the speaker problem but it gave me a reason to heist the Kenwood my woman doesn't use. I'll buy her some flowers to make up for it! Speakers are under warranty anyways.


  7. #7
    Pony Killer Insert's Avatar
    Join Date
    Apr 2008
    Location
    Mississauga, Ontario, Canada
    Age
    29
    Posts
    242

    Black
    2002 Camaro SS M6

    Quote Originally Posted by ezwip View Post
    Also, how do you get the door panels off.
    6 screws to pull out door panels.....

    screw 1 - located on the small triangular piece that sits on top of the door at the front.

    screws 2-6 - the last 4 are located all around the door handle/ arm rest area, just look around.

    after you get screws out, take out the center piece where the door handle is, and the window/lock controls. it is held in by plastic tabs.

    next you pull out the actual door panel, lift it upwards, because it sits on a bunch of plastic hooks. so lift it upwards and the hooks will slide out.

    its fairly easy. hope this helps.

  8. #8
    Member ezwip's Avatar
    Join Date
    May 2008
    Location
    purgatory
    Posts
    354

    Black
    02 Z28 M6

    That will help thank you very much.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Sail subs stopped working! Speakers or amp?
    By 5abivt in forum Stereo and Electronics
    Replies: 5
    Last Post: 10-22-2010, 01:16 AM
  2. Question: Difference between car speakers and home speakers?
    By Kedwin in forum General Help
    Replies: 3
    Last Post: 10-05-2010, 05:11 AM
  3. WTB your working front door monsoon speakers!
    By 5abivt in forum Parts Wanted / Trade
    Replies: 9
    Last Post: 05-30-2009, 12:23 AM
  4. Speakers not working...
    By OnEbAdReDSS in forum Stereo and Electronics
    Replies: 1
    Last Post: 03-20-2007, 08:26 PM
  5. 3 of 4 speakers working ?
    By Joe Romanski in forum Stereo and Electronics
    Replies: 2
    Last Post: 01-28-2006, 11:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •