Results 1 to 4 of 4

Sound Issues Please Help

This is a discussion on Sound Issues Please Help within the Stereo and Electronics forums, part of the General Help category; Last summer I took out my Monsoon radio from my Trans Am and replaced it with a JVC unit and ...

  1. #1
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Sound Issues Please Help

    Last summer I took out my Monsoon radio from my Trans Am and replaced it with a JVC unit and I used the GM wire harness. My front speakers seem weak as hell and I'm not sure why. I've read some threads that there is an amp some place but I have yet to find it? Is it attached to the radio itself or in another location? Also could the factory Pioneer speakers be rated for a different ohm then what my JVC unit is cable to put out? Any help would be appreciated.

  2. #2
    Member Blue28's Avatar
    Join Date
    Nov 2007
    Location
    Ca.
    Posts
    769

    Navy Blue
    1999 Camaro Z28

    Remove the Spare tire access panel and look right over the wheel well, there's you Monsoon Amp.

  3. #3
    its short but its skinny. jiveass's Avatar
    Join Date
    Oct 2009
    Location
    The Woodlands/spring/houston
    Posts
    2,142

    pewter
    99 trans am

    Quote Originally Posted by SMWS6TA View Post
    Last summer I took out my Monsoon radio from my Trans Am and replaced it with a JVC unit and I used the GM wire harness. My front speakers seem weak as hell and I'm not sure why. I've read some threads that there is an amp some place but I have yet to find it? Is it attached to the radio itself or in another location? Also could the factory Pioneer speakers be rated for a different ohm then what my JVC unit is cable to put out? Any help would be appreciated.
    i was not aware that the pioneer made the factory monsoon speakers...either way..to save a headache....i replaced mine with aftermarket speakers and bypassed the amp.

  4. #4
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Quote Originally Posted by Blue28 View Post
    Remove the Spare tire access panel and look right over the wheel well, there's you Monsoon Amp.
    Thx

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 45
    Last Post: 07-21-2016, 09:12 AM
  2. No Sound Help Please
    By screamin chicken in forum Almost Anything Goes
    Replies: 3
    Last Post: 12-01-2007, 01:04 PM
  3. No sound on my PC. WTF?!
    By MagicMan in forum Almost Anything Goes
    Replies: 2
    Last Post: 11-21-2006, 12:30 PM
  4. sound
    By tigersport14 in forum Firebird / WS6
    Replies: 1
    Last Post: 09-11-2006, 06:28 AM
  5. How's this sound
    By TheKitchenSink in forum Dyno Information
    Replies: 6
    Last Post: 08-27-2006, 12:45 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •