Results 1 to 9 of 9

My setup

This is a discussion on My setup within the Stereo and Electronics forums, part of the General Help category; I just got everything installed let me know what you think. Radar installed with hidden wire HUmount(Modded) my JVC KD-AVX77 ...

  1. #1
    Member Orrin's Z's Avatar
    Join Date
    Nov 2006
    Location
    Post Falls, ID
    Posts
    229

    White and black
    2001 SS Artic white

    My setup

    I just got everything installed let me know what you think.

    Radar installed with hidden wire


    HUmount(Modded) my JVC KD-AVX77 didnt fit right.


    Twin 12's in a Subthump custom box


    Dual Halo H.I.D Headlights, and SS fiberglass hood with Hood pins, and grill


    Rockstar rims On the way


    almost done... been a year in the making

  2. #2
    Member
    Join Date
    Jun 2009
    Location
    nor cal
    Posts
    267

    white
    1998

    That setup looks really clean. If you don't mind me asking where did you mount the amp?
    I wish I would have bought one of those subthump enclosures instead of the cheapo I have

    Vacuum time is overdue haha

  3. #3
    Member Orrin's Z's Avatar
    Join Date
    Nov 2006
    Location
    Post Falls, ID
    Posts
    229

    White and black
    2001 SS Artic white

    Yeah it is lol, well it has been really sandy up here with the lack of snow, been a strange year.

    I the cap and amp hiding under the subs, they are kinda geto mounted but they work, and the amp dont over heat belive it or not. cheep setup for heavy bass, cap 1.5f ($20), amp 1200w 2ohm Stereo ($50)

  4. #4
    Member
    Join Date
    Jun 2009
    Location
    nor cal
    Posts
    267

    white
    1998

    excuses excuses whatever dude haha

    I wanted to do that but I'm afraid of overheating my amp. You don't have cooling fans right? While my amps still under warranty I might try this. It looks so much cleaner then having it sit out in the open. Little harder to tell you have a system too in case someone decides to brake in your car.
    Those power acustic amps are supposed to be nice from what I've heard.

  5. #5
    Member Orrin's Z's Avatar
    Join Date
    Nov 2006
    Location
    Post Falls, ID
    Posts
    229

    White and black
    2001 SS Artic white

    yeah it is nice, cheep and beat up, didnt have anyway to mount it before so it slid around, so i drilled two holes in it and tacked it to the floor.

    i really like the clean look, and with the subthump box the ttop storage is easy.

    not to mention that the old mount studs make great grounding spots

  6. #6
    Member mk99z28's Avatar
    Join Date
    Apr 2008
    Location
    WI
    Posts
    281

    Bright Blue Metallic
    1999 Camaro Z28

    looks good man how did you get the blue camaro z28 in the deck?

  7. #7
    Member
    Join Date
    Jun 2009
    Location
    nor cal
    Posts
    267

    white
    1998

    Tacked as in you welded your amp to the ground back there? Maybe a little extreme.

    The embossed z28 logo is an option for subthump boxes.

  8. #8
    Member mk99z28's Avatar
    Join Date
    Apr 2008
    Location
    WI
    Posts
    281

    Bright Blue Metallic
    1999 Camaro Z28

    i ment by the cd player? my car is blue so it would look real nice..

  9. #9
    Member Orrin's Z's Avatar
    Join Date
    Nov 2006
    Location
    Post Falls, ID
    Posts
    229

    White and black
    2001 SS Artic white


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Will a MSD setup really help?
    By Street Fighter in forum General Help
    Replies: 3
    Last Post: 12-31-2010, 10:37 AM
  2. Anyone with this setup?
    By davidz28 in forum External Engine
    Replies: 2
    Last Post: 03-30-2010, 06:33 PM
  3. WTT: My 4L60E setup for your T56 setup!
    By 4birdman in forum Parts For Sale / Trade
    Replies: 1
    Last Post: 03-16-2007, 01:26 PM
  4. Can i run this setup?
    By 94 Formula in forum Forced Induction
    Replies: 4
    Last Post: 01-16-2007, 02:25 PM
  5. will this setup fit?
    By switchblade in forum Wheels and Tires
    Replies: 1
    Last Post: 07-26-2006, 08:36 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •