Results 1 to 6 of 6

Is my AMP broken?

This is a discussion on Is my AMP broken? within the Stereo and Electronics forums, part of the General Help category; My car is in storage and the battery died. So i jumped started it and now my system doesn't work. ...

  1. #1
    Member
    Join Date
    Aug 2005
    Location
    Michigan
    Age
    32
    Posts
    122

    Red
    2002 WS6 Trans Am

    Is my AMP broken?

    My car is in storage and the battery died. So i jumped started it and now my system doesn't work. My amp is off and i don't want to sound dumb but i dont know how to turn it back on. I had it professioanly installed. I was wondering if you guys could tell me how to turn it back on? ITs an ALpine Vpower MRP-M350. Thats al the writing on the amp. Thanks.

  2. #2
    2004 HEAD/CAM CTS-V 9t8z28's Avatar
    Join Date
    Oct 2006
    Location
    doylestown, Pa
    Posts
    6,818

    SILVER
    2004 CTS-V

    Does the HU turn on? Did you check the fuses?

  3. #3
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    it sounds like you probbally blew a fuse. check them.

  4. #4
    Member
    Join Date
    Aug 2005
    Location
    Michigan
    Age
    32
    Posts
    122

    Red
    2002 WS6 Trans Am

    Alright guys I’m sorry but I’m completely Electric stupid. How do I do these things?

  5. #5
    Member
    Join Date
    Aug 2005
    Location
    Michigan
    Age
    32
    Posts
    122

    Red
    2002 WS6 Trans Am

    No it isn't lit up at all

  6. #6
    2004 HEAD/CAM CTS-V 9t8z28's Avatar
    Join Date
    Oct 2006
    Location
    doylestown, Pa
    Posts
    6,818

    SILVER
    2004 CTS-V

    Does the HU (Head Unit) the thing that plays the radio, does that work?
    Lift the hood. Go to the battery, there should be a wire coming off of the positive(RED) cable. 12" from there should be a fuse. Take the fuse out and see if it blew. (((((Do not let the bare ends of the cable touch the car.))))
    What kind of HU do you have? Do you at least know how to work the head unit?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Car Got Broken In To
    By Spikito in forum Camaro / SS
    Replies: 2
    Last Post: 06-26-2008, 02:13 PM
  2. Broken again.
    By stanger88 in forum Manual Transmission
    Replies: 2
    Last Post: 11-16-2007, 09:36 AM
  3. Car broken into
    By Danger731 in forum Western Members
    Replies: 10
    Last Post: 06-21-2007, 10:25 PM
  4. car broken into
    By turbols1chick in forum Texas Members
    Replies: 9
    Last Post: 03-09-2007, 08:03 AM
  5. car almost got broken into;(
    By 01SOMSS! in forum Western Members
    Replies: 21
    Last Post: 02-14-2007, 12:49 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •